I have the LG Optimus P999 from Wind Mobile.

I downloaded ROM Manager and tried to flash a Cyanogenmod ROM (cm-7.2.0-p999.zip). The backup and flash said they went OK. But when it rebooted, it froze at the second LG logo and won't go anywhere. Booting into recovery mode did nothing.

It took many tries to get the LG Optimus unbricking tool to recognize my phone, but I finally got Clockworkmod Recovery to install on it. Now when I boot into recovery mode, nothing works because it can't mount the SD Card.

My next attempt was to flash stock ROM back to it, but I can no longer get the tool to recognize my phone.

Have I totally bricked my phone?

  • That is why I recommend to others, to not use ROM Manager.... :)
    – t0mm13b
    Jan 16, 2013 at 15:42
  • Rom manager is old, outdated and uses the flash_image binary. You need to be sure you are flashing the correct image when using it. (There isn't actually anything wrong with the flash_image binary)
    – Liam W
    Jan 16, 2013 at 16:07

1 Answer 1


Ok, I managed to fix my phone.

The first thing that differed about my phone from the video tutorials I watched was that when you are preparing to flash the phone, you're supposed to hold Vol+ and Vol- then connect the USB cable. In the video tutorials the LG logo came on at that point, but on mine it did not. I figured out that if I plugged in the cable first, then held Vol+ and Vol- the LG logo would come on. This was wrong. The P999 does not display the LG logo when ready to flash. Hold Vol+ and Vol- and then connect the USB cable, wait a few seconds and then let go. Your phone should be ready to flash now. If it's not, try again.

Secondly, this is the software you want to use to flash if you've bricked it: T-Mobile G2X One-Click Recovery Flasher. The version I found on some other websites was outdated and wouldn't fix the problem I had mounting the SD Card (which is actually internal memory on the G2X). With this version I was able to boot into Recovery mode, mount the SD Card manually, and then flash the ROM. I was able able to properly enable USB Mass Storage from recovery mode, which would allow you to copy a new ROM to the SD Card if you've somehow lost your data.

The final issue I ran into was no Google Apps, and no ability to sync my phone to Google. You can grab the Google apps and Flash them through Recovery mode here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .