I downloaded this 80 MB ZIP file containing 27000 files to my SD card and unzipped it using this code.
A no space left error occurred before all files could be extracted.

I couldn't remove the folder, neither with adb shell rm -f nor the Open Manager app nor by mounting the SD card and removing from Ubuntu/Nautilus:

$ adb shell rm -f /sdcard/OxygenGuide
rm failed for /sdcard/OxygenGuide, I/O error


There was an error deleting 08267130495190304.html.
Error removing file: Read-only file system

It looked like trying to remove this particular file makes the whole SD card read-only. Unmounting/remounting made it read/write again, but the same error happened when I tried to delete again.

I decided to reboot, and now I just have a black screen with just the top bar, showing the "Checking SD card" icon and usual network/battery/date. adb logcat shows this:

I/ActivityThread(  323): Publishing provider downloads: com.android.providers.downloads.DownloadProvider
W/Vold    (   71): Filesystem modified - rechecking (pass 2)
I/Vold    (   71): Device /dev/block/vold/179:1, target /mnt/sdcard mounted @ /mnt/secure/staging
D/Vold    (   71): Volume sdcard state changing 3 (Checking) -> 4 (Mounted)
I/ActivityThread(  270): Publishing provider call_log: com.android.providers.contacts.CallLogProvider
W/logwrapper(   71): In fsckdelay end. Kill dosfsck, ret=-1

Android 2.2


Here is how I solved both problems:

1) Remove battery and reboot. Two times because it was still behaving strange the first time.

2) Remove files little by little, until I found the problematic file, called %01.%02, I recognized its content as a tile from the Maverick map app (which I have not launched so it is more of a random casualty). Anyway, I renamed that file to a.a. and then deletion was successful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.