I recently had issue to sync with google as the following are affected:

  1. gmail app says no internet connection
  2. play store says no internet connection
  3. tablet is set to EPOCH (Jan 01, 1970, 00:00)
  4. I can surf the internet but I get tons of certificate warning whatever the website I am surfing.

I am using an android tablet (android 4.0 ice cream sandwich), wifi only. Looking around I found that I should clear data from google services framework and restart my tablet (see this post for example).

It works great, but the error keep coming back and I'm looking for a permanent fix. Should I wipe the tablet?

Thanks in advance for your help!

---- After test update -----

Thanks all for your comments and help (and sorry for my long silence). Here is the steps I've done:

  1. Delete and re-install accounts, Results: Error connecting server (tried with 2 different account)
  2. Done Factory Reset > No more issue to add account
  3. Install Gmail app (it took 3 or 4 trials where I reboot tablet before success). There every was fine.
  4. Restart tablet for testing: same issue as before :(

I guess either I never switch off my tablet or I return it

  • Did you try to also clear the app's cache? Btw: A nice and useful troubleshooting rule graph can be found at Lifehacker :) – Izzy Jan 18 '13 at 10:22
  • yes I did. The issue also affect the time on the tablet as it is set to EPOCH every time the bug is here (edited the question). Thanks for the chart basically it say I'm good for "reset factory data" – magdmartin Jan 18 '13 at 13:56
  • I was afraid so, yes. However, I don't know what else you could try. Just a hint: Before you're going to reset, make a good backup. As you're on ICS, you can backup everything even without root (check my profile page when in doubt, my highest-ranking question deals with that topic). Also don't forget to report back with the results of your reset, if you're doing it. – Izzy Jan 18 '13 at 14:09
  • Before doing a Factory reset, try removing and adding your Google account: maybe this solve your problem. – Francisco Alvarado Jan 18 '13 at 15:01
  • @magdmartin Why is your tablet set to Epoch time? Have you tried setting the clock on it to the right time? A lot of servers and systems have problems communicating with/trusting clients with clocks "skewed" by a few hours, if yours is off by decades that is likely to be causing you problems. – GAThrawn Jan 22 '13 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.