I sometimes have this weird behaviour

  1. My phone has zero mobile network
  2. I decide I should "reboot" the GSM service, and go to airplane mode
  3. I want to disable the airplane mode in order to return to normal state. After a long press on power button, I do have the "device options", however nothing happens when I press Airplane mode (airplane mode enable). I am stuck in airplane mode.

However this option is not disabled (greyed out). Of course, I have a SIM, and it will be detected after a reboot.

The other options from "device options" behave normally (I can turn of sound, turn off device or reboot). It just seems this part of the screen cannot be touched anymore.

Have you experience this? Is it a known bug? How can I disable airplane mode, but rebooting?

Samsung galaxy SII with latest official Android 4.0.4

  • Have you tried disabling it from Settings (i.e. the device configuration)? Does this yield the same problem?
    – Izzy
    Commented Jan 20, 2013 at 16:36
  • 2
    Did you try throwing it into the air? There is a chance it might transform into an actual airplane O:)</offtopic>
    – Sid
    Commented Jan 20, 2013 at 16:45
  • 1
    @Sid lol! maybe attach a plywood with glue to make wings, as paper wings may not work... :P </offtopic> xD
    – t0mm13b
    Commented Jan 20, 2013 at 17:48
  • I think I've seen this once or twice on either a Nexus 7 or a Nexus 4. Not sure how I got around it; I doubt I rebooted the device.
    – offby1
    Commented Jan 20, 2013 at 21:14
  • how long did you wait? Exiting an airplane mode can sometimes take around 3-4 minutes to get a usable connection.
    – Lie Ryan
    Commented Mar 22, 2013 at 3:49

4 Answers 4


This problem usually occurs when, for whatever reason, your phone is set to only use WiFi to make calls in the call preferences menu. On Android, with Jelly Bean upgrade, some apps will alter this setting apparently. Here's the fix. Enjoy!

From home screen, access Apps/Settings/More Settings/Wifi Calling (Press the part to the right of the on/off button to open another menu)/Connection Preferences. Choose either "WiFi Preferred" or "Cellular Network Preferred". Make sure the phone DOES NOT have "Never Use Cellular Network" selected, or every time you shut down your WiFi or go out of range of it, you'll be listed as in Airplane Mode in the on/off menu, but not in the apps/settings/.. menus, because your cellular transceiver is disabled by that setting. Note: These instructions and menu layouts are specific to my Samsung Galaxy S2 with Android 4.1.XXX Jelly Bean, but can easily be adjusted to other phones.

Hope this helps, and my best to all!


Is it a known bug?

Yes, it is. And it seems that it's not fixed yet.

Here are some advises from me:

  1. Try to change SIM card and see what happens.
  2. Backup all your applications (data) and do a hard reset.
  3. Backup all your applications (data) and flash unofficial (custom) firmware. Also try newer version of Android (4.1.x, 4.2.x).
  • Thanks for your answer. However, the issue 22503 seems a bit different. My phone does not go to airplane mode itself. And the menu is not greyed. However comment #19 is very close from what I have
    – rds
    Commented Jan 20, 2013 at 21:34
  • Correct me if I am wrong, but status New means nobody at Android thought it deserved to be Opened.
    – rds
    Commented Jan 20, 2013 at 21:36
  • @rds anyway these bugs are connected with each other (maybe it's even the same bug). And I don't get your second statement. New issue means new issue. I don't know how to explain it. Anyway have you tried my tips? Commented Jan 21, 2013 at 10:12
  • I am with the official ROM now. What unoffial 4.0 ROM is known to fix this? As for Jelly Beans, I have recently searched, and failed to find an unofficial ROM which more advanced than "beta" for 4.1.
    – rds
    Commented Jan 21, 2013 at 12:51
  • there are many stable roms here. Commented Jan 21, 2013 at 13:06

I found the only solution without deleting the System Cache and losing everything was to change to a different SIM card.

There must be some parameter that gets corrupted in Android that is associated with the SIM card. By changing the SIM must use a different set of parameters that are not corrupted.

I tried putting back the original SIM card and the problem returned. I also tried putting my original SIM card in another Android and it also worked OK.


I had the exact same problem since yesterday, this post was the solution http://www.inflightmagazine.co/?p=351

The author refers to two steps to solve the problem, I would add the following steps between Step 1 and Step 2

  • Install BusyBox from the play store
  • Open BusyBox after rooting, grant it superuser permissions
  • Click install on the left bottom corner of the screen
  • You'll be asked to use Smart Install vs Normal Install.. I chose the first option, not sure if it makes any difference if you pick the second one
  • Proceed to step 2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .