My tablet will not connect to ANY WiFi network anymore. Everything was working perfectly for about a month. But now, the WiFi icon has disappeared, and every time I try to connect to a network it simply shows "Saved." I figured maybe it was an issue with my network, so I went out and tested it with other WiFi connections. It can scan and detect everything, but the same thing happens while trying to connect to anything. My Nokia phone and laptop are able to connect to everything perfectly, but the tablet will not, even to the networks which it has previously connected to.

Things I have tried:

  • Deleted all networks by using the "Forget network" option and tried connecting again.
  • Tried "open" type networks without any passwords.
  • Rebooted the tablet several times.
  • Done a factory reset, twice.
  • Tried to analyse logcat data.

Here is a screenshot: enter image description here

I also tried connecting to my laptop using Ad-hoc (with the laptop using a wired ethernet connection and transmitting it to the tablet wirelessly) but no use.

As you can see in the screenshot, the WiFi icon which turns blue and gray is GONE from the notification bar. It never shows up anymore. And the "Saved" result is what comes up every time I try to connect to a network.

I switched the WiFi on and tried connecting to the network while logcat was running, here is the text: http://pastebin.com/9pUba6Tt

The D/CommandListener( 79): Clearing all IP addresses on wlan0 is what happens every time I attempt to connect to any network. Always the same thing.

I have gone through dozens of XDA threads and such with this issue. Many people have gotten the "Saved" problem, but it's only been for people who have UPDATED to ICS 4.0.4 from Gingerbread or something. My tablet CAME with ICS 4.0.4.

P.S: My tablet is a cheap one, it's a Ubislate 7C+ from Datawind.

ANY help would be really, really, appreciated. I've been trying to fix this for about a week now. Thanks.

  • Could it be a hardware issue?
    – Liam W
    Commented Jan 27, 2013 at 10:58
  • @LiamW The device seems to scan and list the wireless networks.. So I doubt it being a hardware issue. The wifi module must still be working.
    – Irfan
    Commented Jan 27, 2013 at 11:16
  • 1
    Yeah, it does scan and detect networks. Turning off a network results in it disappearing from the list. So that's working. It would be nice if someone who is good at analysing logcat could be here. Commented Jan 27, 2013 at 11:26
  • 1
    I did. The link was in the question too: pastebin.com/9pUba6Tt Commented Jan 27, 2013 at 11:33
  • 1
    The strange part of your logcat is lines 249ff, which point to some problem with your WiFi hardware or driver: faied to read proc/net/wireless (repeated multiple times) while initializing the wifi module (insmod wifi driver), repeated across the log. Also check line 272ff plus especially 282ff. Your device really seems to have trouble with the WiFi hardware.
    – Izzy
    Commented Jan 27, 2013 at 14:44

6 Answers 6


Have the "Saved Problem" on a cheap tablet that came with 4.1.1.

Tried 3 different WiFi networks without success: ZyXel P2601HN, Tomato and DD-WRT.

I was about to return the tablet but, as a last resort tried connecting it to an Android phone in tethering mode. That worked - so the WiFi in the tablet was working?

Then I tried a fourth Tomato WiFi router using 802.1b mode - also successful.

It seems this version is picky about the WiFi routers? Could it be the channel assignments - maybe some banned channels due to legislation?

  • Hmm, that's interesting... but what's weird is that my tablet was actually connecting to the networks previously. I've even tried changing the channels... I know ICS supports upto 11 or 12, but I tried everything from channel 1 anyway. Commented Jan 27, 2013 at 16:09

I faced the same issue. After struggling for a few hours, I found the solution.

Login to your Wi-Fi router and change the Wi-Fi channel to anything between 5-11/13. The problem is due to conflict of channels. (I did Google but no help. Then from my experience, I figured out this solution)

One more thing, if your router allows you change data retry and RTS retry settings, then change them to 128. For some reason, at times ubislate 7C+'s Wi-Fi adapter does not respond on time and the router thinks that it has gone out of coverage. So, the device doesn't get connected.



The above static IP solution is a workaround.

The real solution involves changing file permission on a root file.

Fortunately, my ubislate had root access, with help of x-plore file manager, was able to change permission of dhcpcd-run-hook file to read-execute(no write) in the /system/etc/dhcpcd directory.

Works like a charm. More details in the below URL


  • sjec, please add an excerpt of the instructions from behind the links. Once the links die, your answer will be useless otherwise.
    – Izzy
    Commented Apr 13, 2013 at 18:04

I had the same problem with my Asus tablet. Everything was working fine until one day it stopped connecting.

Not a geek so I tried everything that you have done (all of that!!!) and as a last resort went to my router settings and turned of the "lock". The Asus connected immediately. Turned the lock back on and it still connects. The only issue I have now is that any time that I turn off the tablet or take it away from the network, I have to go through the same process as before.

Tell me if that works through this website.

  • 1
    Lock? What do you mean by lock? Commented Feb 11, 2013 at 1:19
  • 2
    I think he meant to turn off "wifi security" (open wifi)
    – Irfan
    Commented Feb 11, 2013 at 12:35

The tablet is fine, it's your router that's the problem. Chances are that you're using a cheapie like a Belkin or something similar. If its something that you bought from a discount store for about $35 then you're going to have issues with it with the tablet and other wireless stuff. Upgrade to a real router, a high-quality dual-band one. The tablet will work without any connection problems after you do this.


I recently had this problem with my Nexus 7 running KitKat 4.4.2. I fixed the problem by rebooting my router (Netgear DG834GT)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .