I'm trying to root my phone with Unrevoked recovery reflash tool and it all goes well - it installed the needed service and the root tool - up until it's supposed to actually do the root process.

It reboots the phone and then says "waiting for system to settle" and then it says "running root". Then it gives me the message "error: failed to get root. Is your firmware too new?"

waiting for system to settle

running root

failed to get root

But how do I tell if my firmware is too new? Do they mean the Android build number? And where can I see what versions are supported? Or is it my HBOOT version that's causes the problem?

Some info about my device.

Android version

Baseband version

Kernel version

Build number
2.29.405.2 CL263770 release-keys

Software number

Aug 10 2010,17:52:18

Is this thing compatible with Unrevoked or not?

If not, will it help to downgrade to Android Eclair 2.1 RUU and then try to root?

Update: Downgrade attempt failed

I just tried downgrading from 2.29.405.2 to 2.10.405.2 using the RUU_Bravo_Froyo_HTC_WWE_2.10.405.2_R_Radio_32.44.00.32U_5.09.05.30_2_release_142828_signed.exe file but the process failed. I get error code 140 - "bootloader version error".

ruu update 1

ruu update 2

ruu udpate 3

ruu update 4

ruu update 5

So much for plan B...

  • I used the Revolutionary tool and it worked like a charm!
    – Samir
    Commented Jun 10, 2013 at 10:49

1 Answer 1


One click root methods use a simple rootkit exploit package to gain root permissions to the Android kernel. Once this is done, they modify file permissions to make the rooting permanent.

These exploits have been patched by Google and device manufacturers for a long time now, and the vast majority of one click rooting solutions are outdated and no longer work.

In other words - your firmware is too new. It has been patched against rootkit exploits.

  • And Unrevoked reflash tool is also one of these one click root methods? Will it help to downgrade to an older RUU? If not, what other options do I have?
    – Samir
    Commented Jan 27, 2013 at 12:57
  • It was not possible to flash an older RUU than the current one used. I'm not sure if this is a general rule or policy (like with iPhone) or just an anomaly. But I managed to flash with the same RUU version as the one that was currently on the phone. And after doing that I tried Unrevoked again and it worked. I'm not sure if the RUU (with the same version number) that I downloaded was modified in any way, or if it was just my current ROM (although same version) that was messy. I would say it was most likely patched up by updates and blocked Unrevoked.
    – Samir
    Commented Jan 27, 2013 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .