I just got root with Unrevoked and S-OFF with AlphaRev. I partitioned my SD card in GParted as following.

Part 1: 4096 MB ext3
Part 2: 25842 MB fat32

The card is a 32 GB SD card. I intended to have 4 GB reserved for apps and such. Now I am trying to do a NANDroid backup using the new ClockWorkMod AlphaRev Recovery But it keeps failing and says that /sdcard can't be mounted.

I tried to navigate to Mounts and storage, and then Mount /sdcard but it gives me an error.

CWM-AlphaRev Recovery v2.5.1.8
E:Can't mount /dev/block/mmcblk0p1 (or /dev/block/mmcblk0)
(Invalid argument)
Can't mount /sdcard

//I attempted mounting it manually here.//

E:Can't mount /dev/block/mmcblk0p1 (or /dev/block/mmcblk0)
(Invalid argument)
Error mounting SDCARD:!

I noticed that, after partitioning the SD card and rebooting the phone and loading Windows, when I clicked to do a safe unmount of USB drive in Windows there was a message in Android that said it was safe to unmount the SD card now. ????....

And then I went into recovery mode in Android and found out that it couldn't do a backup because it couldn't mount the SD card. Is my SD card damaged or what? Do I have to do some kind of data/cache wipe first?

I had the phone shut down since the last attempt, just to make sure that the SD card really gets mounted when booting up. But that didn't help at all.


I tried a solution I found over at XDA forums.

In CMD, go to dir C:\Android\android-sdk\Tools Type: path C:\Android\android-sdk\Platform-tools)

Input "fastboot oem enableqxdm 0"

But I tried this and it says < waiting for device > in my CMD prompt and nothing happens. Does the phone really communicate with the computer in this mode? My ClockWorkMod screen has changed to an icon of a white software box with a blue android mascot next to it. So it looks like it is in this so called fastboot mode now.

C:\>adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
List of devices attached
SH08KPL03467    recovery

C:\>fastboot oem enableqxdm 0
< waiting for device >

So it looks like the daemon was not running but the phone definitely communicates with the computer. Do I have to press some button? I tried mounting the SD card again and it still doesn't work.

  • 1
    1. You need fast boot drivers and 2. the main fat partition should be partition 1 :-)
    – Liam W
    Commented Jan 27, 2013 at 21:26
  • Do I have to use GParted again for this? Can I use some app instead? Over at XDA forum I've read different reports, some users suggest that this problem might be cause by the use of GParted for partitioning of the card. But I will go ahead and give your suggestion a try.
    – Samir
    Commented Jan 27, 2013 at 21:28
  • Just to check "fast boot drivers" are the drivers published by Unrevoked and on various sources like XDA forums, the package is called "android-usb-driver.zip" right?
    – Samir
    Commented Jan 27, 2013 at 21:31
  • @LiamW Thanks! That really helped. I reformatted the SD card in GParted and made the fat32 partition the first partition (/dev/sdf1) and the ext3 partition the last partition (/dev/sdf2). The CWM-AlphaRev Recovery is now making the backup. If you want you can write your comment as answer so that I can mark it as a solution to the problem. Maybe you can expand that a little? I still wonder what fast boot drivers are. And why this even matters...
    – Samir
    Commented Jan 27, 2013 at 21:51

1 Answer 1


Recovery images are hard coded to use the first partition of an SD card are the main FAT partition.

As such, you need to ensure that the first partition on the card is the FAT partition, or recovery will try to mount the ext partition as the fat partition.

You can use any partition tool to modify the card.

You also said that fastboot wouldn't work - this is most likely due to lack of fast boot drivers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .