I just installed Jelly Bean 4.1.2 on my Samsung Galaxy Note N7000. I am not able to add words to the dictionary. I use more than one language while texting. There are no options in the settings either.

How do I get myself out of this rut?

  • When you type in a word that is not in the standard dictionary and then click on it do you not get the prompt "<-- Touch again to save"? Also are you using the stock keyboard or a different one? – ZnewmaN Jan 28 '13 at 19:24

Ok I believe I'm a step closer to solving this adding to the dictionary issue. This is how I'm getting around it

Firstly my keyboard is set to portrait type 3x4 Predictive text on with continuous input. Now to add a word turn OFF predictive text.

Now type your word manually and when your done, and with the cursor flashing directly next to the end of your word, goback into settings and turn predictive text back ON.

Now when you back out of setting you should see your word in the suggestion list above the keypad. Tap your new word and you should find it added to your dictionary.

This method also works for email addresses. Just to be clear this is for use on Android 4.1.2 my device for all concerned is Samsung GS2. Let me know if this helps.


I have been able to add and edit words on my Samsung Galaxy S2 running Jellybean 4.1.2 by using a free app called QuickShortcutMaker. The app allows me to create a home screen shortcut to the user dictionary.

A detailed tutorial can be found here: How to Add & Edit Words in the User Dictionary on Jelly Bean 4.1.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.