The apps worked this morning for a bit, then I plugged my phone in to charger and grabbed it right before I left for work.

When I was checking it on the way to work, most if not all of my apps, said 'Application is not installed on your phone'.

I've tried restarting many times and un-mounting and mounting the SD card again.

Can anyone help, please?!

  • 1
    Something does not sound right about this! Why did you unmount the SDCard? are the apps on SDCard? what device, what Android version, what exactly happened to get that message? – t0mm13b Jan 28 '13 at 17:02
  • I unmounted the SD card because all of the applications that are not working say SD next to them on the application menu. On the home screen it just displays a little android guy in place of the app icon. I figured the card was not in properly or something so I unmounted & remounted it. I can't even access the Play store because that says it's not installed on phone as well. When i go to settings and applications it says there are a few installed on SD card but the ones installed are gray and have the SD next to them. I have the Samsung Galaxy SII and the Android version 4.0.4 – user27479 Jan 28 '13 at 17:10
  • Let me clarify, in the settings - applications in the 'Downloaded' section it shows the gray apps with SD next to them. In the 'On SD card' section it shows 4 apps that work. Very confusing! – user27479 Jan 28 '13 at 17:13
  • I plugged it into my wall charger. – user27479 Jan 28 '13 at 17:35
  • Not exactly sure now... the sdcard was probably unmounted and replaced the usual application icon with the android guy? – t0mm13b Jan 28 '13 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.