2

I rooted my Android ICS with some script. It was rooted then I installed and removed some system application. Then I formatted the device and re-installed the ICS.

Now when I try to root it again it gives error could not copy are you a root? I searched for that and finally found that though I re-flashed it any times. /system is read-only. So then after I tried

adb shell
mount

then command of mount and it gives error permission denied. Please help to reset the permission of /system so I can manually add the su file in it.

The technique i used to Root is at this link. Then i format using cwm and install new rom. Now i am not able to root it.

10
  • 1
    I would say that more information is probably needed. Like what device, how you rooted the device. you do not have permission to run "mount", unless you are root, to make /system not read-only, you have to have root. /system is read-only on purpose. there is nothing to fix there, it should be read-only. Commented Jan 29, 2013 at 14:40
  • What is the some script you are referring to?
    – t0mm13b
    Commented Jan 29, 2013 at 14:57
  • i have added the link in question please check it. Commented Jan 29, 2013 at 17:11
  • "using cwm and install new rom". Are you sure the ROM you installed doesn't already have root? What ROM did you install? Commented Jan 29, 2013 at 21:21
  • Reinstalling ICS will revert the file you changed...
    – Liam W
    Commented Jan 29, 2013 at 21:42

1 Answer 1

0

I have posted the question on same link shown in question. Till that i tried everything format SD card totally, also tried different roms of ICS still it was not worked.

Then as in reply i got on that forum saying install gingerbread rom then root it, use OTA root keeper and upgrade.

So i did similar to that i installed gingerbread.

Then i formatted all using cwm. Then i installed new ICS refrec v2 rom. And then after i tried to root it. And it worked. Hope so if anyone face the same problem they can downgrade to GB then again move to ICS to root it after flash if their favorite rom doesn't come rooted. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .