On my Samsung Galaxy Nexus running AOKP 4.2 JellyBean, WiFi has worked without issue before on this exact same hotspot, and it is currently working for other devices, so I'm assuming the error is in the phone. After trying another hotspot, I could see that the WiFi is definitely dead. But after enabling encryption on my device, it gets stuck in a loop. It detects the actual network, but it goes like this:

Saved with X authentication > Authenticating> Obtaining IP address > (Repeat)

I also tried deleting the network and adding it again without success, thinking it had something to do with the cached WPA key.

Is there anything I can do to troubleshoot before I just wipe and reinstall? Is this some kind of known issue?

  • 2
    Try to connect your device with ADB and have a look at the adb logcat for error messages. You don't need to install the entire SDK for this: The ADB Guide on AndroidForums contains a "MiniSDK" (Linux, Mac, Windows versions) to download which should be fully sufficient for this. Report back then with conrete error messages.
    – Izzy
    Jan 31, 2013 at 12:55
  • I found something interesting, not sure what else to look for as I don't feel like posting all of the 9k+ lines I got would make sense, also there's some personal info in there. Anyway, I found this: E/DhcpStateMachine( 1029): DHCP failed on wlan0: Timed out waiting for dhcpcd to start
    – pzkpfw
    Jan 31, 2013 at 16:49
  • Here's some more from the logs, tried to clean it up as well as I could: pastebin.com/LL9vFhL0
    – pzkpfw
    Jan 31, 2013 at 16:53
  • That looks like your router does not want to talk to your device. Might be a MAC filter. Try looking up your device's MAC address, and check whether this is permitted to connect to your WiFi (who knows, maybe encryption also encrypted your MAC address ;)
    – Izzy
    Jan 31, 2013 at 16:54
  • @Izzy it most definitely is not, exactly the same on two separate hotspots that have previously worked. I think the DHCP negotiation is timing out extremely fast for some reason. Oh well, time to wipe I guess.
    – pzkpfw
    Jan 31, 2013 at 16:55

2 Answers 2


Might be some interoperability issue with a particular hotspot. If it is a DHCP time-out, you can try assigning a manual IP address to the particular network.

Or if it is a rooted device, you can try the below command inside adb shell:

dhcpcd wlan0
  • It's not related to the particular hotspot, read my post again.
    – pzkpfw
    Feb 2, 2013 at 10:07
  • +1 for the terminal command. Helped me to find out the file permission problem.
    – Arthur
    Oct 5, 2015 at 15:34

From the 4th revision of the OP's question,

Re-locked and unlocked bootloader, flashed recovery via Galaxy Nexus Toolkit and pushed a new AOKP via ADB, installed it and everything is working fine now. No idea what caused it, but I'm pretty sure the full device encryption screwed something up. However, since CWM doesn't even support full device encryption, it feels like a bug relating to it is kind of low priority since people shouldn't encrypt their devices with customs ROMs anyway and expect a smooth ride.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .