I hope someone can please help me!! I have had my galaxy s2 for about 1 year with no problems until now. I have never dropped the phone or gotten it wet etc...today I forgot to pay my bill and phone was shut off by ATT. Once I realized, I paid the bill and had it turned back on. When it came back on, I could make and receive calls however I Could not connect to the internet or use facebook without turning on WIFI.

If I tried to use internet with no WIFI it said no internet connection. I then decided to turn the phone off by pressing and holding down the power button. I waited a few seconds then tried to turn the phone back on. It began to boot up by flashing the normal samsung galaxy s2 screen. Instead of fully booting, it continually flashes the samsung galaxy s2 screen over and over. After 10+ minutes of this, I decided to remove the battery and try it that way. I am still having the same issue!

The battery is fully charged and when I try to connect it to my computer, the computer does not reconize any decives. I have a lot of pictures, videos and contacts that I am extremely afraid to lose because I have not copied them to my computer for quite some time....I pray that someone can please help me!!

  • 1
    Just for starters have you tried pulling the battery?
    – znewman
    Commented Feb 1, 2013 at 3:06
  • yes I pulled the battery and put it back in...I pushed the power button and the same thing is still happening. now I somehow have gotten it into ODIN MODE, dont ask me how...This screen has the lil green robot it says ODIN MODE, Product name: SGH-1777, custom binary download: NO, Current binary: samsung official...then it says underneath the robot downloading do not turn off target
    – user27670
    Commented Feb 1, 2013 at 3:12
  • Is your phone rooted and is usb debugging enabled?
    – znewman
    Commented Feb 1, 2013 at 3:17
  • ok please do not get angry, but I have no clue what you just said? I have the phone plugged into my computer with the cord it uses to charge...I am really not tech savy sorry...
    – user27670
    Commented Feb 1, 2013 at 3:20
  • My answer is the best I can do as far as offering anything that may help you. I hope the instructions are clear enough. You may want to wait to see if anyone else responds.
    – znewman
    Commented Feb 1, 2013 at 3:39

3 Answers 3


As far as I can tell this is what you need to do. NOTE: This information comes from my research and not my experience and while this may make your phone usable you may lose your data. I suggest removing your microSD card as it is most likely where your pictures and video are:

  1. Download ODIN from here
  2. Register at Sammobile here
  3. Download your firmware here
  4. Open ODIN
  5. Put your Firmware.tar file in the PDA box and tick PDA (DO NOT TICK OR UNTICK ANYTHING ELSE)
  6. Attach your phone to your computer using your USB cable and click Start. Don't do anything else until it is done.
  • thank you so much i will try that out! I pray the pictures are not gone :( thank you for your help!
    – user27670
    Commented Feb 1, 2013 at 3:42
  • @user27670 How did it go?
    – HXCaine
    Commented May 15, 2013 at 10:07

Use @ZnewmaN 's method to backup your data. As for what's wrong with the phone, a similar thing happened to my Nexus One sometime back. It just kept on loading and never actually finished booting. Just go to the boot screen or what ever it is called, (usually when you turn on the phone keep the volume down button pressed and press power button) and do a factory reset and it should be fine.

  • thank you for your suggestions....the phone actually crashed...it was completely stuck in a "boot loop"...I had to actually call the samsung head quarters to try to figure something out...I did the power volume buttons and it always went back to boot loop. We even tried to wipe it out back to the factory settings and straight back to the boot loop...Samsung was even amazed :) all my personal information was gone, but I now have 3 different accounts to sync all my contacts and pictures to!! Thank you all for all your help!
    – user27670
    Commented Feb 2, 2013 at 0:00
  • oh brother, it's 21st century, sync all your important stuff to the clouds up above. :) But hey clouds can disappear as well right? so make sure you have a plan for that as well.
    – JanithaR
    Commented Feb 2, 2013 at 9:41

It's possible that the button is stucked. All you have to do is hold down the power button until it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .