1

I have been having a lot of trouble trying to extract a boot.img. Its one of Samsung's with the funky headers so none of the scripts work. I tried HEX editing it so it is a gzip (1f 8b 08) and removing whats in front of the 1f (kernel i believe) but to no avail. All i need to do is get to init.rc and edit it then re-pack.

  • 1
    Samsung's boot images are different, and they are not in img format IIRC, rather they use their own rfs (That's what it is AFAICT) – t0mm13b Feb 1 '13 at 22:34
  • am i allowed to link to a download site? because i will just upload the boot.img – user27713 Feb 1 '13 at 22:41
  • Dont know if i am allowed but here is the boot.img. If someone couple please extract it and send me the files / tell me how they did it then i would be truely grateful. dropbox.com/s/q0rswokt4a7l4nj/boot.img – user27713 Feb 2 '13 at 0:04
  • Look here – t0mm13b Feb 2 '13 at 0:06
  • I found that before but i just tried again, and as with all of the other tries/ways and i still get the same cpio error.This is only part of the output for it was too long. dropbox.com/s/6e3cse4rbq2s3tf/cpio.txt – user27713 Feb 2 '13 at 2:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.