I lost my data upgrading to M1 CM10.1 through CMUpdate, but I still see it when I go into clockwork recovery mod. I tried accessing it through adb and adb shell but I cannot find it. Furthermore my Galaxy Nexus is reporting that it's full.

I have tried this method: http://forum.xda-developers.com/showthread.php?t=1994705 However, it does not recover all my data and if it does it's often renamed and/or corrupted (i.e. images merged together, mp3s losing metadata, and so on)

Is there a way to access it using CWM and copy it to my PC? What commands is CWM using to access that otherwise inaccessible data that I could run from adb?

I tried tweeting the CWM guy but he never got back to me.


If you were going from CM10 to CM10.1 — that is, moving from Android 4.1 to 4.2 — your data "loss" is probably because the path to your emulated SD card has changed due to the new multiuser support. Previously, the SD card was /data/media, but now it's a subdirectory such as /data/media/0, with additional subdirectories (such as /data/media/1) for additional user accounts. The files should've been moved to the new location automatically when you first booted CM10.1, but maybe that didn't happen.

Using a root file manager or shell, create a /data/media/0 directory if it doesn't exist already, and then move all the other files from /data/media into the 0 subdirectory, and it should become visible within Android again.

If you use ClockworkMod for backups, you may find that it can no longer find your backups directory, because it's still looking for /data/media/clockworkmod, not /data/media/0/clockworkmod. You can fix that by creating a symlink in the old location. From a root shell, run these two commands:

cd /data/media
ln -s 0/clockworkmod clockworkmod
| improve this answer | |
  • I selected this one as answer because it is THE solution, though thanks to Koush i was able to find the data as well. – Nimchip Feb 3 '13 at 23:46
  • you are a wonderful human being – anon58192932 Jun 28 '13 at 18:46

Use adb shell and look in /data/media.

Should be there.

| improve this answer | |
  • Welcome @koush to ASE! The hallowed creator of CWM!!!! As your first time here.... +1... :D – t0mm13b Feb 3 '13 at 0:17
  • Thank you so much, after a bit of fiddling with remounting I was able to get all the stuff I needed :) – Nimchip Feb 3 '13 at 23:34

Titanium Backup offers this when you have the Pro key.

To get a copy from the cwm folder you can use adb pull.

| improve this answer | |
  • I can't because it it's inaccessible on adb shell, using the pc or cyanogen file manager so there's absolutely no way I could point to the folder. It's only under clockwork that I am able to see it. – Nimchip Feb 2 '13 at 21:02
  • Also not sure how Titanium would help me, I only need to recover my media. I don't care about the apps. – Nimchip Feb 2 '13 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.