It runs Android 2.3.6 and has the kernel version. I've already tried using SuperOneClick but it doesn't work. :(

I'm rather contented with it ( oh wait, it has this puny internal storage, 120+ mb, but I can live with that ) and I'd rather just leave it alone except for the fact that Huawei saw it fit not to add proxy support. My university network uses proxies so the smartphone is rather useless at school. I tried proxy apps but they all require the phone to be rooted. I hope somebody here can guide me in rooting this phone. Thank you for your time :)


I tried SRSRoot as @Izzy suggested, unfortunately, it doesn't work either :(

    ---= SRS One-Click-Root v4.3 =---

11:29:51 PM - Starting ADB Server..
11:29:57 PM - Manufacturer: HUAWEI
11:29:58 PM - Model: HUAWEI Y210-0100
11:29:58 PM - Android Version: 2.3.6
11:29:58 PM - Build ID: Y210-0100V100R001C294B837
11:29:58 PM - Board ID: Y210-0100
11:29:58 PM - Chipset Platform: msm7k
11:29:58 PM - Getting OffSets.. : 0x8003 0x8005 (False) 
11:30:00 PM - Query Server for Best Method.. Found Rootkit: 2

    ----= Start Rooting Process.. Please Wait =----

11:30:00 PM [+] Testing exploit: root2a (Please wait it can take some minutes)....
11:30:21 PM [+] Executing root2a exploit Failed, Proceed next...
11:30:21 PM [+] Testing exploit: root4 (please wait..)
11:30:24 PM [+] Device Reboot #1 (Wait till it's started)
11:33:23 PM [+] Executing root4 exploit Failed.  (Root Error: 0)
11:33:23 PM [+] Testing exploit: root4b (please wait..)
11:33:27 PM [+] Device Reboot #1 (Wait till it's started)
11:36:45 PM [+] Device Reboot #2 (Wait till it's started)

11:39:57 PM Auto Root Failed on this device. :( 

11:39:57 PM Rebooting Device and try again... 
  • If it's just for web traffic, you might also want to take a look at SandroProxy, which claims to not require root. But as from the description, it's browser only. There's also Proxymator which doesn't mention root.
    – Izzy
    Feb 8, 2013 at 10:27
  • @Izzy Tried them both. Unfortunately, both don't work for me :(
    – R.K.
    Mar 8, 2013 at 8:28
  • 1
    OK, so back to the root(s): you might want to try SRSRoot, which explicitly mentions to support your device. Let us know if it worked -- best would be to answer your own questions then and describe how you succeeded :)
    – Izzy
    Mar 8, 2013 at 9:32
  • @Izzy Woot! Many thanks :D Downloading now... :) I wonder why it never turned up on my searches. Will post the results later :)
    – R.K.
    Mar 11, 2013 at 7:40
  • 1
    You may ask them -- I cannot tell :) Two other places I found and you might to check: A request on rootpros.com (though no bids yet, but you may watch it), and a strange file on adbrootkit.com (no idea whether that is safe, though)...
    – Izzy
    Mar 11, 2013 at 16:46

3 Answers 3


That was for y210D. You need to flash it stock again and root it with a y210 insecure boot image. You can get the stock ROM here.

  • Thanks! This one worked. Would you know where I can get the insecure boot image?
    – R.K.
    Apr 5, 2013 at 9:49
  • Hi @frank, could you provide a step by step guide? That way people can follow this without leaving the site.
    – R.K.
    May 8, 2013 at 1:28

you may try this at your own risk. Please do a nand back-up first.

  • 2
    What is the linky containing? Elaborate more please.
    – t0mm13b
    Apr 6, 2013 at 13:47

I know it's been years but I think people might be interested to know how to root this. I tried again last month using Framaroot. You just download the latest version, install the app and run it. Most painless root I've had so far.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .