Recently I received via email an .epub file (eBook). When I try to download it I get an error message that says "Aucune application ne peux afficher la pièce jointe" (no application can show the attached file).

There was a short time I don't read on my Android phone, so when I have the first error message I have uninstalled and reinstalled the Aldiko app.

But my phone still tells me with "Aucune application ne peux afficher la pièce jointe" (no application can show the attached file).

Has anyone had the same problem? Does anyone have a resolution?

  • Have you tried download the .epub to your computer and transferring it to your phone? Also, What phone? what version of Android?
    – znewman
    Commented Feb 8, 2013 at 16:15
  • Android 4.0.4 on Samsung Galaxy SII (I9100 i think). Erh... i don't have any cable with me & my computer don't have bluetooth nor wifi.
    – lumiweb
    Commented Feb 8, 2013 at 16:19
  • Do you have dropbox or google drive?
    – znewman
    Commented Feb 8, 2013 at 16:22
  • seems to be blocked in my computer (but i have it in my phone, i could try in a other place...). Except if it always possible to send a document to GDrive via email...
    – lumiweb
    Commented Feb 8, 2013 at 16:26
  • What app you are using to download/retrieve the .epub file?
    – Izzy
    Commented Feb 8, 2013 at 16:40

1 Answer 1


There are multiple solutions. As I don't know how you tried to download it (or with which app you received it), I'll give you a few "blind shots":

  • Downloading it with the browser: This might give you the error you described (see below for a possible solution on this), or might simply store the file in your downloads folder (depending on the browser used). In the latter case, the saved file is often mis-named to .epub.html, so you'd have to rename it and strip the .html off to be able to open the book with your reader.
  • Receiving it with the mail/gmail app: There should be a way to simply "save the attachment" to your sdcard. You need to find the correct folder with some eBook readers; Aldiko might offer you to import it to its library from wherever you've stored it.
  • Downloading it with your PC, and copying it to your device: Same steps as above after saving the attachment.
  • Try Moon+ Reader as alternative eBook Reader app: As far as I remember, Moon+ registers itself for the .epub extension, which should completely solve your problem with the error message (the book would be opened directly in Moon+ Reader). And even if not, it has a lot of OPDS libraries pre-configured where you can download books from directly from within the app.

One or more of above items should help you out of your misery. Enjoy eBook reading!

PS: If you like Moon+: Until the end of this month (February 28, 2013), the Pro version (Moon+ Reader Pro) is offered for half of its usual price to celebrate its return to the playstore after having been unfairly banned. This is an offer you should take then :)

  • Glad I could help! Enjoy reading :)
    – Izzy
    Commented Feb 11, 2013 at 13:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .