My mobile data keeps turning on by itself and uses my data traffic. I think this is because of WhatsApp, but I'm not sure. Is there any other possible reason aside from WhatsApp? How should I stop it from happening?

Phone: Samsung GT9100i
Android Version: 4.2.1

  • 1
    If you are already guess it is whatsapp -- have you tried removing it and see if your problem goes away? As you specified you're running Android 4.2, you could simply disable it (via settings->apps->manage apps), so you wouldn't lose any data this way (and could re-enable it later if you want to).
    – Izzy
    Feb 11, 2013 at 12:41
  • If you want to check if whatsapp is causing your data issues, check out the apps mentioned here: android.stackexchange.com/questions/26178/…
    – geffchang
    Feb 11, 2013 at 12:42
  • I believe its battery saving app, disable it or force stop battery saving app and then check. I tried on my mobile and now its working fine.
    – user152201
    Feb 19, 2016 at 14:02

2 Answers 2


What other apps related to mobile data are you using? Is there any battery saver app that are using? they can turn your data on or off automatically. Whatsapp doesn't have the permission to enable mobile data. So it must be some other app. still you can use 3G WatchDog to check if whatsapp is the culprit.

  • RACHIT u're right.... If u re using battery defender application then uninstall it or click on disable notification battery if the defender is on... Av tried it and work for me..... Catch ur fun buddy
    – user58574
    Apr 15, 2014 at 10:34

For Samsung, go to Settings> Connections> Data Usage then press menu button. Select Restrict Background from the menu. It will stop turning on mobile data automatically.

  • 3
    I very much doubt that – it's rather the other way around: turning off mobile data would stop background data along its path. Background data should only be active with mobile data (or WiFi) being enabled – but they should not enable it automatically. No data means no data, and that includes no background data.
    – Izzy
    Sep 1, 2015 at 23:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .