On my Nexus 4, there's a folder called /sdcard/Music/ (or just /Music when browsing the phone's storage; Windows 7 calls it Computer\Nexus 4\Internal storage\Music) and I've put a lot of songs in there but the music player doesn't see any of my songs. Why can one app (the file manager, and e.g. Dropbox) see the files, but not another app (Play Music, Apollo, Jukefox)?


  • LG Nexus 4 16GB, unlocked, with CyanogenMod 10.1
    (nightly build 20130212 because nothing more stable is available but there are no crashes.)
  • The songs are stored in the path format /sdcard/Music/Artist/Album/Song title.mp3 (simply because that's how they're stored on my media drive).
    • Computer\Nexus 4\Internal storage\Music\Eagles\On the Border\1 Already Gone.mp3
    • Computer\Nexus 4\Internal storage\Music\Kashmir\The Good Life\10 Kiss me goodbye.mp3
    • Computer\Nexus 4\Internal storage\Music\Christina St眉rmer\Freier Fall\1 Geh nicht wenn du kommst.mp3
      (yes there's a Chinese character in there and I don't know why; it's a German ü (umlaut u) on my original Windows media drive)
  • I know that the songs are present and that they work because the CyanogenMod File Manager shows them and I can play them individually. They do exist!
  • Running Rescan SD as suggested below didn't make the files appear in any of the player apps.
  • I'm fairly certain there are no .nomedia files: The CyanogenMod File Manager doesn't display files that begin with a . (I renamed an existing TXT file and it promptly disappeared :)) but I used the Root Browser Lite to look through /Music and subfolders -- the only match I found was the one I had renamed, and I have deleted that now.
  • My Windows pc at work couldn't see the files either, but after unplugging/replugging the USB it now can see+open+play the files. (I've now revised this question to remove the Windows part.)
  • I'm still mystified by the fact that file-browser apps see the files but music-player apps don't.
  • Do you have ROM Manager installed?
    – geffchang
    Commented Feb 13, 2013 at 11:51
  • @GreenGuy: Yes - why does it matter? Commented Feb 13, 2013 at 12:19
  • As GAThrawn mentioned, there may be a .nomedia file, which might be related to ROM Manager. Look for this .nomedia file and delete it.
    – geffchang
    Commented Feb 13, 2013 at 12:20
  • Apollo is the Cyanogen music player. As for your files: Can you mention some example file names? Might be a compatibility issue, and before one asks for the type, the next for special characters in the names, etc., it might be easiest to have some "full examples" available ;)
    – Izzy
    Commented Feb 13, 2013 at 13:23
  • 1
    Just my guess: The media scanner could have "crashed" at those. For a test, try removing/renaming files with Umlauts and other special chars (luckily we are not French or Turkish, or it would be more :) Those "Chinese" thingies most likely turn in when Windows doesn't care and simply uses its own charset (MSANSI or WIN-1252 or whatever), while Android thinks it is UTF8. That's why I avoid Umlauts etc. in file names (though the word "Gruesse" looks really weird this way ;))
    – Izzy
    Commented Feb 13, 2013 at 15:22

15 Answers 15


Seeing a file name like Computer\Nexus 4\Internal storage\Music\Christina St眉rmer\Freier Fall\1 Geh nicht wenn du kommst.mp3 points to a special problem with "special characters" (such as German Umlauts) which got messed up on data transfer: While Windoze uses its own character set (MS-ANSI or wone of the WIN-12xx, depending on configuration), Android expects UTF-8 -- which is why it's a good custom to use only 7-bit ASCII characters in file names.

Due to this mismatch and the "unidentifyable character", the media scanner most likely has crashed. Which resulted in the media database not being populated, from which follows: The players think "no media files there".

Proposed actions

I'd suggest to either temporarily delete or at least rename all affected files, so that no file with "special characters" in its name remains. Then have the media scanner run again (e.g. triggering it with Rescan SD). Once that's finished, I'm pretty sure your media player(s) will find something to play (with).

That being approved, you know what to look for in the future. As said before, I strongly recommend to restict characters in file names to 7-bit ASCII -- that avoids a lot of problems, though some names might look a little strange ;)

  • Accepted: Because everything worked just fine after a reboot, your hypothesis about a crashed media server was probably correct. I'd hate to have to limit my files to 80's-era ASCII names so I'll leave them alone for now -- it seems to work, and the characters actually show correctly as umlauts in the app (no Chinese!). Commented Feb 13, 2013 at 16:29
  • 3
    The app most likely uses the ID3 tags of the MP3 files, which might at least explain that part. I still wonder that the files still appear, and did not crash the media scanner on subsequent runs: if they crashed it in the first place, why did they work at all? But most important: issue solved :)
    – Izzy
    Commented Feb 13, 2013 at 16:40
  • 2
    To rescan the media, one can also use a clearly open-source app, SD Scanner, from F-Droid. Commented Apr 20, 2014 at 10:45
  • After the rescan, it helped me to kill the Apollo app (with long-pressing the "back" button in CyanogenMod) and starting it again -- to get the updated list of albums in Apollo. Commented Apr 20, 2014 at 10:46
  • Thanks for the answer! It was useful for me after I uploaded a music album to my CyanogenMod device through ssh, and couldn't figure out how to make Apollo see and play it (as a whole album). Commented Apr 20, 2014 at 11:03

In the stock ROM the Nexus 4 default music player should be "Play Music" with an icon that looks like yellow headphones, never heard of Apollo but it's possible this is something your custom ROM's changed.

Most music players on Android get their "media library" from the built-in media scanner service, this should pick up MP3 files stored in any user-accessible storage location on your phone and add them to the scanner's library. Sometimes the media scanner doesn't "notice" new files you've just added and needs to be told to do a rescan, there are apps on the store that can do this, such as Rescan SD, you can find a selection of them with a search of the Play Store if you run one of those and wait a couple of minutes all of your media should be picked up.

It's unlikely from what you're saying, but it's also possible that a hidden .nomedia file may be sitting in your Music folder, or one of it's parent/child folders. The presence of this file tells the media scanner to ignore the contents of that folder and it's child-folders. If you find that file somewhere in your Music folder's hierarchy, delete it.

  • Oh, I also have "Play Music" but when I launched it, I thought it was a music store (buy songs from Google Play) -- my mistake. I launched it again just now and it says "No music kept on device." The Settings menu just has two non-touchable lines: open source licences and music version v4.5.9101.560208. Commented Feb 13, 2013 at 12:22
  • 1
    Apollo is the default player of Cyanogen, is also available on Play store. Just for clarify.
    – PaNaVTEC
    Commented Feb 13, 2013 at 12:32
  • I've updated my question: Rescan didn't help, and I'm fairly certain there are no .nomedia files. Intriguing! Commented Feb 13, 2013 at 13:00
  • It might be unsupported formats as well. Not sure which formats are supported by what player, but I could imagine that some don't support .ogg, for example, while others do. Another cause might be the sampling rate/method -- but that should not affect the "being seen" but the "playing fine" part.
    – Izzy
    Commented Feb 13, 2013 at 13:28
  • @Izzy: I see what you mean, but the file manager can play the files so I would think that both the path and the format is valid and works. It's just that the player apps seem oblivious to it... Commented Feb 13, 2013 at 14:27

Neither the pre-installed android music app nor Apollo music player could see the files I side-loaded until I flattened the directory hierarchy to one-level. For example, Music/Band/song.ogg works, Music/Band/Album/song.ogg does not. If only music players could see through those shallow id3 tags and get back to basics!

  • This. All contemporary music players seem to take ID3 as gospel, when the fact is that such data is frequently misspelled, corrupted, misleading or just plain wrong. If only my android player could just play a folder, and sort the entries by file name. Corrupted sorting due to bad ID3, or a "deep" hierarchy, has made entire audio books entirely unlistenable to me, frequently requiring me to merge 200+ 5MB .mp3's with custom made single use scripts. Commented Oct 19, 2014 at 0:38

Had the same problem on Android 4.4.2. My solution:

  1. move sdcard/Music to sdcard/media/Music
  2. reboot to recovery mode
  3. wipe cache (system cache, not the dalvik one)
  4. reboot system

enjoy with Google Play Music! ^_^


move sdcard/Music to sdcard/Media/Music reboot opo. All files showed up on players.

  • What is 'opo' here?
    – Firelord
    Commented Jul 22, 2015 at 10:56

Delete the .nomedia found on your music folder. Internal and external sd card music folder. Install player pro media player. Go to settings and point it to where your music folder at on your external sd card. Once your songs showed up, it will show on your stock music player too. Good luck

  • Could you please include a link to the mentioned app? It will be hard to find otherwise, as many apps have "player pro" in their names/descriptions. Thanks!
    – Izzy
    Commented Jun 14, 2013 at 20:07

Your music library might not be set up to scan even the /sdcard0/Music/ folder.

Connect your android phone the your computer and active "USB Mode"

On your computer access the SD card on your phone over the USB cable. So on windows it might look like "F:\Music\" as a drive letter.

So, in this instance my issue looked like this "F:\Music\Music_aa\" I renamed it to "F:\Music\Music_ab\"

The Android USB helper service on the phone automatically starts a new scan for all media inside /sdcard/Music/Music_ab on the phone once you disconnect from USB mode.

Hope this helps.


Ok guys.... Last night out of the blue my stock android media apps album and music player could not find any of the photos or songs that were actually in my sd card. After escaping a stroke by a little....and four hours letter after readind a lot of forums I found a solution:

For the music player I used an app called "Next music" which could actually see the songs. I went to an option called scan by hitting the refresh button, did a full scan and magically my songs were readable by every other app including the stock player. Without any rebooting

For the photos I used quickpick. It was the only one that could actually see the photos. I opened each folder in my album then by pressing the hard menu key there was an option called" Fix Date". Did that for every folder and tbey appeared on my stock album app. Without rebooting

Ps :deleting every .nomedia I found did absolutely nothing...

  • "Next music" found only sound recorder files (on the external SD card). No other music found (stored on the internal SD card). The My Files app does see the music files, as well as AirDroid. Commented May 30, 2015 at 21:03

I had this problem and I found the solution, when you go to your phones "file manager", disable "show hidden files". Then the installed players will not recognize your mp3 files. So make sure the hidden files are hidden in the file manager.

  • 1
    Seems weird, as I can't find any relation with that setting. Just my 2 cents.
    – Andrew T.
    Commented May 12, 2015 at 6:27

I experienced the same thing on my Samsung Galaxy S3 mini.
I just used Rescan SD/Rescan (used them both because I wasn't sure where my music was SD card/Internal SD)
After that - it just worked and my Samsung stock music player worked!!


I had the same problem with the Samsung Galaxy s5 running cyanogenmod. Here is what i did. I put the music into my internal storage and it was working fine. Then i copyed the files over to sd\media\Music, if you dont have these folders, create them. Then test and see if the file shows up by deleting one of the songs in the internal storage. if it doesnt pop up, then unmount and remount the sd card.


Rename the folder or move your files to Some new folder like (Music/). It will automatically fetch your mp3 files.


Create folder media/Music. Put all your media folders and files. Make readdressing and rescanning in your player (I use VLC) Problem should be resolved.(LinageOS 15.1 on Nexus 5X)


.nomedia - I had 2 of them files on phone and one on sd - deleted all three and Hay Presto Music player now sees all songs on SD card and phone - all good thanks - using Samsung Galaxy Ace 4 lite - had tried reformatting SD - reboots of phone - different media players - but by deleting all .nomedia files was the only solution that worked - worked a treat - didn't even have to reboot phone - just a quick rescan from media player


I mounted and un mounted my sd card and all apps recognized the files again


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .