My Galaxy S II started to act weirdly recently - application can't be installed or updated neither in Google Play, nor locally, the Settings > Apps (Storage) says "Computing" forever, my SD card fails to dismount etc. But other than that, the phone operates normally - all files are accessible, all apps work etc.

As I needed the updates and installs to work, I needed to fix this. It appeared that when I physically take the SD card out, all is suddenly fine. When I put the card back in, I can access the data on it, the files are visible over MTP on my Windows machine etc. but the above mentioned problems are back again.

I've checked the card itself and it seems to be fine - it operates normally under Windows, the Windows check tool didn't find any corrupted sectors or anything like that. So I guess the fault is either in my phone or in Android - does this sound familiar to someone here? Is there anything I can do to try to fix this?

1 Answer 1


tl;dr: Have you tried with another SD card already? Have you tried the SD card on another phone? Try formatting the SD card and resetting the phone.

Maybe there is some problem with a file on the SD card, that isn't recognized by your computer, but that your phone doesn't like. Maybe you could try to format your SD card, so that everything is removed (also the possibly bad file). Or check if you have the same problem on your phone with another SD card.

Could be that this doesn't fix your problem, then I would suggest you try to reset your phone (don't forget to take a backup of course). And see if you still have the problem.

If this (formatting SD + resetting phone) also doesn't help, then I am out of ideas. Maybe then there is something wrong with your hardware, but I hope one of the above will fix the problem.

  • Thanks. I've tried a different SD card (16GB this time, my newer one is 32GB) but it is still the same. Really strange - the card is "working" - I can access it via file explorer, over MTP etc. but its presence causes problems to seemingly unrelated parts of the Android OS. Commented Feb 13, 2013 at 13:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .