My Motorola Atrix 4G (MB860) is stuck in a crash/reboot loop. I believe it is running Android 2.3.6, but the phone doesn't stay on long enough to confirm.

It seems this is a common problem (why is that?), but most of the potential solutions I've seen on the Internet haven't been particularly helpful. I can't seem to boot into Safe Mode, because I instead get stuck at a "Starting RSD protocol support" message that does not progress. I have tried clearing the cache, but that has no effect.

I have had this happen in the past, but in those cases I was able to escape the loop by powering down the phone on purpose and restarting it manually. That solution is not working this time around.

I have a lot of data on this phone that I would like to at least be able to salvage before I have to wipe the phone with a factory reset (if it does indeed come to that), but the phone does not stay on long enough for it to detect a USB connection or for me to turn USB debugging on to access it with adb.

I have not modified the phone in the past, but I would be willing to do so if it meant that I could get adb working. I would prefer, however, to get at the source of the problem and delete any offending app file that might be causing this to happen (if such a file can be determined).

What is going on here? Why does Android even allow this sort of thing to happen? And why is it not easier to get into Safe Mode?

I suppose those are the more academic questions in this situation, but my primary concern is: How can I gain access to my files to back them up before having to do a factory reset? Or is there another way to escape this crash/reboot loop?

EDIT (2013-02-14):

To be clear, let me elaborate on what I mean by "crash/reboot loop" in this case.

When I power on the phone, it goes through its normal display of the Motorola and carrier screens. Then the lock screen begins to load, as it normally does. It seems to me that it takes longer than usual for it to detect a cell signal and identify the carrier network (AT&T), but I can't know for sure.

At this point, if I don't unlock the phone, it will eventually reboot on its own and continue to loop through this process until the battery dies. But if I do unlock the phone, I am immediately greeted by a series of "Force close" dialog boxes informing me that the following processes/applications have stopped unexpectedly:

  • com.motorola.service.main
  • Google Partner Setup (com.google.android.partnersetup)
  • Google Play Store (com.android.vending)
  • Webtop (com.android.portal)
  • Bluetooth Share (com.android.bluetooth)

I generally have to select "Force close" on the first few in order for the next few to appear, though the Bluetooth one appears immediately on top of the Webtop one. The phone will generally reboot immediately after the Bluetooth error appears. If I have the phone plugged into my computer via USB, I will get a USB connection notification immediately before the phone reboots. I should also note that the com.motorola.service.main error occurs multiple times. (If I "Force close" it, it reappears in between the other errors.) The Google Partner Setup and/or Google Play Store errors sometimes appear multiple times, as well.

EDIT (2013-02-20):

I'm still having issues, so I thought I'd go through the whole thing again, looking for new information. It turns out I missed one key part about booting into Safe Mode: You have to wait until the boot ANIMATION starts before holding both volume buttons down. (Then you keep holding until a long vibration occurs.)

Anyway, when I booted into Safe Mode, things got worse, not better. The phone didn't even stay on long enough for it to complete the Android initialization!

I don't know what that means, but maybe it's another clue?

  • 1
    have you tried clearing the cache from recovery which is accessed via Power button + Vol Down key... – t0mm13b Feb 14 '13 at 1:10
  • Yes; as I said, it had no effect. – GPHemsley Feb 14 '13 at 2:07
  • What did you do exactly for this to happen? I am suspecting a buggy/incorrect kernel that has caused a bootloop which is indicated by the phone does not stay on long enough for it to detect a USB connection That is an indication which is making me suspect of that! – t0mm13b Feb 14 '13 at 14:42
  • 1
    There's no explanation and because that question is inducing speculation because there is this big catch-22 in that you cannot get at adb and USB recognition! Had it being the reverse, i.e. can use adb and USB, it would have been a matter of posting the log here and a more explanation would be deduced from that, unfortunately! Now bootloops are a sign of flashing wrong firmware/broken ROMs/broken kernels/broken apps. Can you remember what apps you last installed? – t0mm13b Feb 14 '13 at 20:07
  • 1
    In all fairness, you should have mentioned that in the very beginning.. Since you are not rooted, adb shell in recovery is limited and therefore will be a restricted adb shell, the most suggestion I can think of right now, is this, create a recovery flashable zip to remove the offending apps in place, and try wiping the dalvik cache at the same time... – t0mm13b Feb 14 '13 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.