I just installed Cyanogenmod 10 on my Transformer TF101 and every time I try to connect to my home network, it says 'Connecting...' then it goes to 'Saved, secured with WPA' without the internet connection.

  • Any debug log (logcat or router log)? Otherwise it's hard to guess, with the crystal ball broken... – Izzy Feb 17 '13 at 22:13
  • If you have MAC blacklist on your AP, check if the MAC has changed when you've installed CM10. Also check your WPA passphrase. – Peter Feb 18 '13 at 11:47

I had the same problem after flashing it with CM 10 Nightly, but after debugging on settings, I found a fix. I don't know if it's a bug or what, but what I did was:

  1. 'forget' my network
  2. Connect to it again (make sure your security key is entered correctly)
  3. If still says, "saved, secured with WPA", don't hesitate, you're still not done
  4. On your Wi-Fi window, press your menu button
  5. Choose "Advanced"
  6. There should be a "Wi-Fi frequency band" choice, make sure it's on "auto"
  7. Still not working? Underneath the "Wi-Fi frequency band", there should be "Wi-Fi region code".
  8. I don't know if yours has a choice selected, but mine didn't. I chose "United States" and voila, when I went back, it showed "connected" and my Wi-Fi sign finally showed on my status bar
  • The "Wifi region code" part solved my problem. Thanks! – user80402 Nov 16 '14 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.