1

My phone is a Samsung Galaxy S2, purchased in Singapore. The OS is Android 4.0.3. I wanted to root it, and followed the method specified in this xdadevelopers post.

My kernel is *LPB* (I dont remember the whole thing, and that post says only these 3 letters are relevant anyway).

I tried to follow the instructions and flash both the LPB kernels suggested in that post, but in both cases, while booting, my device shows the Samsung screen with the yellow triangle and then immediately switches off.

I am still able to go to download mode.

1

I solved this by following the feedback from this phandroid post

I used the next higher kernel that is LPD and it worked! .LPH kernel as suggested by another answerer, did NOT work.

The original solution :

Hi, I had the same problem which stumped me as well. I found the answer on a different thread; just use the kernel that is the 'next one up', which in this case is LPD. Works perfectly.

Adding it here just in case someone else comes looking.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.