6

Device: T-Mobile G2 (UK) / HTC Hero OS: 2.1

I have a primary gmail account, a second Gmail account, and a Google Apps account. I'd now like to add another Google Apps account.

However, whenever I try, I get a "you don't have a network connection / This could be a temporary problem or your phone may not be provisioned for data services. lease try again when connected to a mobile network, or connect to a Wi-Fi network. If the problem continues, call Customer Care" message. However I've tried this from 3 cities, across a few weeks, from where I'm always able to access internet and Google accounts.

I presume there's no limit of 3, so what else can I try?

Edit - 3rd Jan - I just tried removing an existing (working) gmail account. I can't add the new account, or put back the removed account - new error is "Can't establish a reliable data connection to the server./This could be a temporary problem or your phone may not be provisioned for data services. If it continues, call Customer Care.". This is on WiFi and 3G - whilst the process was trying I received (pull) email! There's something really wrong.

0

3 Answers 3

1

I have 4 Google accounts, so no there's not a limit of 3. I'm guessing trying two Apps accounts is the problem. Try adding another standard (gmail) Google account and see if that works.

Edit: I'd try a factory reset at this point.

3
  • I don't have another gmail account - can anyone verify?
    – Chris
    Dec 24, 2010 at 17:22
  • That's not it. Just added two apps accounts to my one Gmail account. Sorry I don't have an answer but at least we eliminated a couple of possibilities. Have you verified that your internet connection is active at that moment? Had a problem yesterday where Juice Defender kept knocking mine out while trying to send GV messages.
    – terry1769
    Dec 24, 2010 at 18:49
  • Agree, I have 3 Google Apps accounts, and one normal Gmail account on my phone, with no problem.
    – GAThrawn
    Jan 21, 2011 at 14:20
1

I tried again earlier today, and found it working. Cause of the fix might be: a) enabling multiple login on this account; b) migrating the Google Apps domain to the latest version; c) time, and it fixing itself.

0

I did a Network reset on my phone, and it fixed this issue!

1
  • 1
    Can you tell us how you did that? It is worth mentioning that all the network related details, such as saved Wi-Fi passwords and APNs would be removed by doing network settings reset.
    – Firelord
    Feb 6, 2019 at 5:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .