To gain access to WIFI at university I have to login with my user/pass credentials.

The certificate of their website (the local home page that asks for the credentials) is not recognized as a trusted certificate, so we install it separately on our computers.

The problem is that I don't take my laptop with me often to university, so I usually want to connect using my HTC Magic, but I have no clue on how to install the certificate separately on Android, it is always rejected.

This is what is stated in their website

> Need for installation of official certificates CyberTrust validated by the CRU (http://www.cru.fr/wiki/scs/)

The certificates contain information certified to generate encryption keys for data exchange, called "sensitive" as the password of a user.

By connecting to CanalIP-UPMC, for example, the user must validate the identity of the server accepting the certificate appears on the screen in a "popup window". In reality, the user is unable to validate a certificate knowing, because a simple visual check of the license is impossible.

Therefore, the certificates of the certification authority (CRU-Cybertrust Educationnal-ca.ca Cybertrust and-global-root-ca.ca) must be installed prior to the browser for the validity of the certificate server can be controlled automatically.

Before you connect to the network-UPMC CanalIP you must register in your browser through the certification authority Cybertrust-Educationnal-ca.ca Download the Cybertrust-Educationnal-ca.ca, depending on your browser and select the link below :

With Internet Explorer, click on the link following.

With Firefox, click on the link following.

With Safari, click the link following.

If this procedure is not respected, a real risk is incurred by the user: that of being robbed password LDAP directory UPMC. A malicious server may in fact try very easily attack type "man-in-the-middle" by posing as the legitimate server at UPMC.

The theft of a password allows the attacker to steal an identity for transactions over the Internet can engage the responsibility of the user trapped ...

This is their website : http://www.canalip.upmc.fr/doc/Default.htm (in French, Google-translate it :))

Anyone knows how to install a web certificate on Android?

  • Is your Phone locked down or do you have access to the filesystem? – Josh Oct 14 '09 at 20:46
  • I think I can access to the file system, there is the debug mode that give you a root access, but what this have to do with certificates? – martani_net Oct 14 '09 at 23:06
  • So just browsing to that site does not give you some option to permanently accept the certificate? – Arjan Oct 16 '09 at 20:48
  • No, actually the browser asks to ignore the certificate, when I hit yes, it shows a failure page. This happens even on a pc, FireFox fails also to load a page even if I tell it to ignore the certificate, so if I download it separately and double click it, everything works normally – martani_net Oct 16 '09 at 21:56
  • 1
    Rather than stating in your question that you solved the problem, you should create a new answer with the solution, then accept that answer. – ale Feb 1 '11 at 16:08

For Android 2.2, the certificates (without renaming or converting) can be placed at the root of the sd card.

To install:

  1. Go to the Settings/Security menu, Credential storage section.

  2. Activate Use secure credentials.

  3. Click Install from SD card.

  4. A menu will appear with the available certificates.

  5. Click on each certificate to install.

Those certificates will then be available to the wifi system.

| improve this answer | |

I know this is late coming, but I designed a tool just for this purpose. I was having trouble with my Droid, so I created this tool: RealmB's Android Certificate Installer. I know it works with Android 2.0 (the OS which runs on the Droid), but I don't know for 1.5 or 1.6. Feel free to give it a try.

| improve this answer | |
  • actually I found a tool called wifihelper that do just that and it works for 1.5 and 1.6, check out this post here martani.net/2009/11/install-wpa-certificates-cer-files-on.html – martani_net Feb 1 '10 at 13:46
  • the martani.net app was complex, so I cannot be sure I used it right; in any case, I followed instructions and it didn't seem to have any effect. I also tried RealmB's installer, and that appeared to "work", in the sense that when I pointed my phone's browser at the link that the site provides, the phone popped up a dialog asking me what name to give the certificate. On the other hand, I still cannot connect to my wireless network :-| – offby1 Feb 2 '10 at 21:04

I've done it typing in the browser "file:/" plus the name of the certificate file in the SD

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy