I used to run CyanogenMod 9.1 with device encryption on my Galaxy S3, and decided today that I wanted to try a CM 10 nightly.

A problem with device encryption that I didn't know about before is that it's impossible to turn off. ClockworkMod Recovery ( can't mount the /data partition (and, by extension, /sdcard). This means that I can't use CWM to factory reset or install a new update.zip, since the update.zip must lie on the internal sdcard.

Trying "choose zip from sdcard" gives "E:Can't mount /sdcard/" and choosing "apply /sdcard/update.zip" gives "E:Can't mount /sdcard/update.zip". This happens even if I've used adb to put the update.zip in the /sdcard mountpoint.

Factory resetting from CWM gives these two errors: "Error mounting /data!" and "Error mounting /sdcard/.android_secure!". Factory resetting from CM9 didn't work. I've since tried to flash CM10 with MobileOdin, which didn't work, and now I can only boot to CWM.

Does anyone have any idea about how I could mount /data or otherwise get a working ROM?

I've taken backups of everything. The tools I suppose could help me, but I haven't tried because I'm new at this and don't want to hard-brick my phone, are fastboot and heimdall.

TL;DR: S3 only boots to CWM, but CWM won't mount /data and so can't flash zips.

2 Answers 2


I fixed mine right now. Using Odin, load the original image of your phone from the exact provider in pda. Now, it's like brand new.

P.S. You have to unrar the image file, or Odin won't see it. After you unrar, it should have a MD5 file.

  • Thanks! I've never used Odin. Looks like a Windows program? I don't have access to a Windows computer =/ Mar 3, 2013 at 7:03

Have you tried to reboot to the bootloader? You can do so using adb reboot bootloader. From there, you can flash boot.img and system.img. Look at fastboot options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .