Galaxy Nexus does not charge when powered on, but it charges properly when powered off. Phone doesn't detect USB connection also. This happened without any reason. Phone is not rooted.

Tried different cable, charger, everything.

2 Answers 2


That sounds to me like a hardware issue. If you're still under warranty, I'd get it repaired. If not, you'll have to decide whether you want to live with it or pay for repair (or replace the phone).

  • 1
    @forums,@Scott: I am able to charge using a 2A charger even when turned on. So is it not a hardware related issue?Any idea ?
    – Rilwan
    Mar 8, 2013 at 8:26
  • That sounds to me even more like a hardware issue, as I can't imagine that the software would care or even know about the charger's amperage. Mar 8, 2013 at 13:12

Do you happen to be using a 3rd party charger?

500mAh chargers cannot charge the Nexus while on, 1Ah chargers can but might struggle. I recommend chargers with 1.5Ah for charging high-end devices

Alternatively, the problem might lie with the power management of your ROM. Have you also installed an app recently before this happened?

  • Thanks for reply, I tried different charger with 1.5A also.I have not installed any app, I just flashed to new 4.2.2 JB image. But after seeing the issue flashed back to 4.2.1. Still issue persists.My main issue is not getting charged, USB is not detecting. I can charge device with turned off.
    – Rilwan
    Mar 4, 2013 at 6:32
  • 1
    It might also be a kernel problem (if it's custom made). Honestly I don't have any more ideas.
    – forums
    Mar 4, 2013 at 7:02
  • Thanks.I am not sure, even i tried stock images from google.
    – Rilwan
    Mar 4, 2013 at 7:11
  • @Rilwan: Your question says that the phone isn't rooted, but here you mention that you've flashed a custom ROM. That's important information that should be in your question.
    – ale
    Mar 4, 2013 at 13:54
  • @user267:I flashed a custom ROM(rooted one) then flashed back stock ROM. That's why i did not mention rooted.
    – Rilwan
    Mar 5, 2013 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .