I have an HTC Desire HD. I am having trouble connecting to the Google Play Store. Every time I try to connect it just come up with an error "NO CONNECTION". I really want to download some apps (in particular Words With Friends). I know I am connected to the Internet; I can access my mail and Facebook, etc.

I have uninstalled Play Store and re-installed it but no luck!

How can I fix this?

  • Have you tried the usual steps to deal with a truculent app?
    – ale
    Commented Mar 4, 2013 at 18:16
  • 2
    Also, how did you uninstall/reinstall the Play Store?
    – ale
    Commented Mar 4, 2013 at 18:19
  • I had a similar issue and found it was due to having previously installed Adblock-Plus. It requires you set up a localhost proxy in your WiFi connections. When I removed Adblock-Plus I forgot to undo the proxy settings. When I removed the proxy the connection worked fine. Commented Aug 26, 2014 at 0:06
  • @SteveLorimer My I ask what procedures you did to undo the proxy settings, does proxy affect /system/etc/hosts?
    – Albert
    Commented Jul 15, 2018 at 14:39
  • Update google-play-store Commented Jul 22, 2019 at 13:12

3 Answers 3


Solution 1
You need to uninstall(only after force stop it & clear data and cache) Freedom app in your mobile phone if you have. There are some reports that Freedom App causes "No Connection" error.

Solution 2 -
Check your Gmail / Google account password. Have you recently changed it? If yes, then you will need to re-enter your password on your Android device to get all your Google services back. As soon as you change your Google account password, your device gets a notification to enter the new password. Do it or your Google Play Store or any other Google service will not sync or work properly.

Solution 3 -
Clear the Play Store cache. The Google Play Store app on your Android device stores some cache data on your device which could be one of the reasons why you are not able to connect to Google servers using the app and keep getting the “No connection – Retry” error message. How to fix it?

Read the quick and easy steps below:

  1. Go to Settings > Apps.
  2. Scroll to All apps and then scroll down to “Google Play Store” app.
  3. Open the app details and tap on the “Force stop” button.
  4. Then, tap on the “Clear cache” button.

That’s it. Now start the Google Play Store app on your phone / tablet and it should load and work absolutely fine!

Solution 4 -
Check the date and time of your device. Yes, this was the problem with majority of users complaining about this error message in their Google Play Store app. If your date and time are not correctly set, you will again the “No connection – Retry” error message.

  • I was facing the same issue as i had installed the freedom app on my device and then uninstalled it.. Once it was uninstalled i lost the play store with the no connection error. Once i installed it back again it started working Commented Aug 4, 2014 at 3:08
  • 2
    My old Android phone's date was 3 years behind. Updating the date/time resolved the No Connection - Retry issue for me. Thanks.
    – Eben Geer
    Commented Jan 29, 2015 at 22:10
  • Google Play Services kept crashing on a Nook but I fixed that and now I'm getting this error. None of these solutions work (I can't find how to change the time, but it appears accurate). Any other ideas? Commented May 6, 2018 at 18:21
  • I found I had to restart my phone for the above to take effect. @TravisBemrose
    – stanri
    Commented May 17, 2021 at 18:25

Make Sure that Background data is enabled on your Phone.

For 4.0 (ICS), check it in Settings > Data Usage > Menu > Uncheck Restrict Background Data.

For any other Android flavor, look for Backgound data in Settings, and try enabling it.

It might help you.

  • If background data restricted he should get a notification that "Background data is restricted" while he opens Playstore(Not "No Connection" error).
    – Akhil
    Commented Mar 5, 2013 at 10:20

The other answers did not work for me, but I did find a potential work around.

I opened my /etc/hosts/ file in a text editor and added a # in front of Google's IP address, commenting it out. After that, I was able to connect again. You'll need to be root in order to do this.

  • I installed some stupid ad blocker in my device which put the wrong ip in hosts. Fixed it by deleting the hosts file itself.
    – GorvGoyl
    Commented Feb 26, 2017 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .