4

I have a Samsung Galaxy S2 that has suddenly stopped being able to sync my calendars and contacts with GMail. Every time I try, I get the message sync is currently experiencing problems. It will be back shortly.

The only thing I've tried to do is to remove and then re-instate my account, but still no joy. Has anyone had this problem before? What have I done or am I doing wrong?

I don't think it's anything new that I've installed because it was syncing fine up till about a month ago, and that's long after I installed non-native apps such as Go contacts.

  • Just experienced the same on SGS2 running JB. Calendar hadn't sync'ed in 5 days, contacts hadn't in more than a week. Found out because I was looking for events I knew I had added - no warnings or anything :-( – abstrask May 6 '13 at 17:30
2

Try these things:

  1. Go to the tablet's System Settings/Account (Google), tap your account name, make sure Calendar is checked for sync.

  2. Go to the Calendar app's Settings, tap your account name, and make sure the calendars that you want synced are checked.

OR

Settings-->Apps--> click on the ALL tab-->Calendar.
Then Clear Data.
Then go back to Settings-->Accounts-->Google--> Tap on Calender for sync.

Short cut name will change according to which android version you are using.

  • 2
    On my SGS2 running JB, I solved it by clearing "Calendar Storage" and "Contacts Storage". Thanks for the hint. – abstrask May 6 '13 at 17:28
0

Go to the tablet's System Settings/Account.
Set automatic sync.

Go to Google account.
Check sync people details.
Check sync app details.
Check sync calendar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.