I have an app (EBookDroid) that automatically opens all PDF links instead of letting me download them. Is there any way to stop this without uninstalling the app?

I'm on unrooted Android 4.2 and using Chrome as my browser.

Note that EBookDroid has no defaults set. If I open a PDF with a file manager then I'm given the option to choose an app to open it with.


2 Answers 2


Since EbookDroid is open source, I took a quick glance at the AndroidManifest.xml, the pertinent information is this part, between lines 24 and 33:

            <action android:name="android.intent.action.VIEW"/>
            <category android:name="android.intent.category.DEFAULT"/>
            <category android:name="android.intent.category.BROWSABLE"/>
            <data android:host="*"/>
            <data android:scheme="file" />
            <data android:scheme="smb" />
            <data android:scheme="content" />
            <data android:scheme="http" />
            <data android:scheme="https" />
.... SNIP ....

The keyword(s) is in the Intent Filter's category

  • android.intent.category.BROWSABLE
  • and the android:scheme="http"

With both of these, the app "listens" on the http/https both web, plain and secure and among others such as smb for samba file shares, etc, for the content links that contains the pdf, djvu and others, identified by the lines between 35 and 43:

<data android:pathPattern=".*\\.pdf" />
<data android:pathPattern=".*\\.djvu" />
<data android:pathPattern=".*\\.djv" />
<data android:pathPattern=".*\\.xps" />
<data android:pathPattern=".*\\.oxps" />
<data android:pathPattern=".*\\.cbz" />
<data android:pathPattern=".*\\.cbr" />
<data android:pathPattern=".*\\.fb2" />
<data android:pathPattern=".*\\.fb2\\.zip" />

This will explain why the app hijacks any browser downloads and thusly

that automatically opens all PDF links instead of letting me download them

Why not post an issue on the same site to let the developer know about this?


I had the same problem, but found out that disabling handle http in the ebookdroid settings fixes the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .