Having an OTG Data Cable, I connected different thumb drives to my Nexus S – running JB 4.1.2 – but my phone doesn't seem to read them. The thumb drives I tried are:

  • a 16GB Kingston G3 Data Traveler USB 2.0
  • a 16GB Sandisk Cruzer Fit Mini USB 2.0
  • and a 2GB generic drive

What else is needed in order to access that memory?

Is there anything along the lines of the Nexus Media Importer but for Nexus S?


I also have a Nexus S device (running CyanogenMod 11, Android 4.4.4 KitKat), and it seems Nexus S does not support USB OTG. I tried connecting an external USB keyboard and also a USB mouse, and it did not work. The mouse LED for the optical sensor did not even light up.

So, I believe that either the hardware does not have support for USB OTG, or you might need a custom firmware with a custom kernel to make it work (I believe this is unlikely).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.