1

Since yesterday, I cannot browse to www.aemet.es (the Spanish national weather service). Instead, it goes to m.antena3.com (a TV station). This happens both with the built-in browser and with Chrome.

Following the advice found here, I've cleared the cache (or I've tried to) but the problem persists. I've also tried a hard reboot.

What else can I do?

My device is a Samsung Galaxy S3, unrooted, running Android 4.1.2

  • 1
    I think it might be a problem with the ISP's DNS. Have you used WiFi of a different ISP and 3G and get the same results? – forums Mar 7 '13 at 7:41
  • Well, my PC is in the same network and reaches the site just fine. But if I try through 3G, it goes to the wrong one, but a "Forbidden" message appears, instead of opening the site. – MikMik Mar 7 '13 at 7:50
  • 1
    Then problem most probably lies with your ISP, their DNS might be outdated or poisoned to point your browser to a wrong site. You might want to let them know of this issue so they can fix it for you. – forums Mar 7 '13 at 7:56
  • Solved! I've changed the DNS of my router to google's public DNS and now works fine. – MikMik Mar 7 '13 at 7:58
  • good for you :D this is a common issue also with our ISP that's why I use OpenDNS as a counter. – forums Mar 7 '13 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.