I have a very strange problem:

I have an LG Optimus 2x which uses Cyanogen mod 7. I've had this installed for almost 1 year now, and haven't made any updates or installed any apps for months.

A few days ago, I connected the phone to my laptop to transfer some stuff, and I noticed that the touch screen wasn't responding. Neither did the Android buttons, which I suspect use the same touch sensor as the screen. Everything else seemed fine, physical buttons (power, volume) work ok, the phone is detected when connected to usb, notifs on screen and such work ok.

After multiple trial & errors, I've discovered that if I shut down my phone, and re-start it, when it gets to the screen where I must input my SIM Pin code, the touch screen is still not working, but if I wait like 1-2 minutes, it starts working. From here on end it works fine until I close (lock) the phone. At that point if I press the power button to unlock it, the lock screen is unoperable as the touch screen no longer responds. I can re-do this over and over.

My question is then: anyone has an idea what this can be and how to fix it? For example on my Asus tablet, there's a hard reset option (hold volume down and power while rebooting). I've used this to cure that Asus tablet of the fact that sound was no longer working all of a sudden. I haven't managed to find a similar option for Optimus LG 2x.

Also, is it safe to assume that the screen is not phisically broken, since a reboot and 2-3 minutes of waiting makes it so that it works just fine?


This really sucks. I've whiped everything and installed the latest cyanogen mod. Still the same issue. Simply put: the screen has to stay on for like 2-3 minutes before the touch starts to work. If the screen is closed (by closing or restarting the phone) touch will not work again until the screen is on for 2-3 minutes. Kind of a hair-puller.

  • 1
    This happened to one of my tablets also. What I did is put it in the fridge (not the freezer), inside an airtight plastic bag for an hour. After that the screen worked. I am guessing it is caused by moisture that grounds the touchscreen to the board. – forums Mar 7 '13 at 14:16
  • Thanks, at this point I'm willing to try anything since otherwise the thing is useless. I honestlly thought along those lines as well, it's clear that somethingi is "offing" the touch screen now and again, it's not the power button, it's not the software. I don't really get how cold can help with this, but I'm gonna try anyway. Thanks, will keep you posted. – Shivan Dragon Mar 7 '13 at 15:10
  • Well I tried your solution, didn't work. Apparently the thing is really broken. Thanks anyways for the help. – Shivan Dragon Mar 12 '13 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.