Recently my HTC Sensation got stuck in a boot loop. I've tried factory reset and recovery to no avail. Upon getting to the screen, I get the following:





PG58DIAG.zip ...No image

PG58IAG.nbh ... No image or wrong image

PG58IMG.zip ... No image

PG58IMG.nbh ... No image or wrong image

PG58IMG.tar ... No image


Any advise on possible fixes would be much appreciated as my phone is no longer under warranty and the alternative is giving my carrier more money. Whilst I am a complete n00b to it, I would not be unwilling to root the device if it could solve my problem (if it's even possible at this stage).


  • Did the boot-loop come out-of-the-blue, or was there something "special" you did before? Where you trying to flash something?
    – Izzy
    Commented Mar 10, 2013 at 18:31
  • Boot-loop came completely without warning. I was trying to use google maps and got a message that my phone couldn't connect. Thinking nothing of it, I decided to reboot the phone and that's when the loop began.
    – user29933
    Commented Mar 10, 2013 at 18:40
  • Very strange. The listing you included with your question seems to indicate your device is looking for/at several image files (probably located on your SDCard?). PG58DIAG is a tool used e.g. to unlock your device. Similar messages are discussed at XDA, and again here (check the last link first).
    – Izzy
    Commented Mar 10, 2013 at 18:53
  • PS: Doing a Google Search suggests a failed (ICS?) update. Did you have an OTA notice you approved, so it might have tried to start the update in the background?
    – Izzy
    Commented Mar 10, 2013 at 18:56
  • Not that I can recall re: the OTA notification. As I've said, I haven't made any attempt to unlock my device as I felt it was beyond my ability and most likely to brick it. At this stage, Three has wiped their hands clean and told me to either upgrade early or GTFO. As such, whilst I still feel I may screw it up, I've got nothing to lose. Would it be possible for me to recovery any functionality at this point?
    – user29933
    Commented Mar 10, 2013 at 19:03


You must log in to answer this question.

Browse other questions tagged .