I just installed Android 2.1 on my Pandigital Novel. Anytime I try to download an app (via WiFi), I get this error:

Unable to download. Not enough space on phone.

However, the phone lists the free space as being 125.57MB, about 25 times the size of the file I wanted to install.

I took the APKs I was trying to download and put them on my SD card. I was able to install them to the device from there proving it does indeed have space.

What should I do?

  • It's listing internal storage as 125mb free, right? Not the SD card?
    – Bryan Denny
    Dec 28, 2010 at 14:19
  • @Bryan: Correct. It lists the SD card(correctly) as having 8Gb.
    – John
    Dec 28, 2010 at 14:57
  • hmmm.... I'm not familiar with your device. It's a eReader/tablet sort of like a Nook Color? Are you installing apps via Android Market or some other market? Or via ADB? The only other thing I can think of to suggest is to run a logging app (or use DDMS with the Android SDK to get a log) and see if it is saying anything else in the logs while installing.
    – Bryan Denny
    Dec 28, 2010 at 15:04
  • @Bryan: It started life as an eReader. pandigital.net/pandigitalnovel - I have the white one. Then I put other firmware on it: slatedroid.com/index.php?topic=5098.0 - The very last link in the first post of that(linked) thread. I am downloading APKs from market websites but not using an app. I could not get ADB to detect my device. I will look at LogCat.
    – John
    Dec 28, 2010 at 15:36
  • Its a lot of stuff that doesn't work if it is not enough free Internal Storage - like receiving tiny SMS. You could try a one time clean with MemoryCleaner.
    – Olav
    Jan 4, 2013 at 7:48

8 Answers 8


This doesn't answer why it doesn't work, but...

As a workaround, if you have an SD card, you can insert it and it will automatically download to the card instead.


Another workaround that worked for me in a similar case was to restart my device.

I guess that the application is trying to find a continuous free space of about 5MB and memory is not fragmented efficiently (there are many chunks of 4MB or less). Somehow memory is rearranged after restart but maybe the explanation is different.

  • 1
    I doubt fragmentation is an issue here. It's rather that due to the restart some temp stuff might have been cleared up (e.g. something left in /data/local), and thus some space was freed up. But apart from that: yes, a restart can do that, sometimes :)
    – Izzy
    Jun 8, 2013 at 11:23

Note: the following seems to work only on Samsung devices

Enter the number *#9900# in the dialer (no need to press the Call button) and the SysDump menu will appear, there select the second item (Delete dumpstate/logcat). This will delete some "hidden" system log files you didn't know exists and don't need. They can be up to a gigabyte big and cause mysterious "Cannot download, not enough space" and similar "no space" messages, when the system info otherwise claims there is plenty of space free.

Some suggest a restart after the deleting.

  • Incorrect code :(
    – HasH_BrowN
    Dec 21, 2014 at 22:20
  • Maybe it works only on Samsung devices? Dec 22, 2014 at 0:13
  • Unfortunately, the device in this instance does not have any phone functionality. Can you elaborate on other ways to find these hidden files?
    – John
    Dec 22, 2014 at 23:51
  • According to this forum message (german), you can try to open the recovery menu and select the "wipe/clean cache" item there to get the same effect. The recovery menu is opened by turning the device off, the turning it on while holding some buttons. Which buttons depends on the device - google it. Also try to find more information about the wipe/clean cache operation, I never used it. Feb 11, 2015 at 12:04

I'm experiencing this problem too, and my experience revealed that it's only the latest version of the app store causing the problem.

So every time I want to install or update apps, I first revert the Play Store to the stock version.
I go to the app drawer, long click the Play Store icon and drag it to "App Info" to open its settings (you can reach there via Settings->Apps->Google Play Store), the press "Uninstall updates".
It will install updates in the following short period, until the Play Store app is upgraded again.
Please comment on if there is a way to prevent the Play Store from updating itself automatically (auto-update apps is set to false).

Hope this helps.


This is a very annoying problem I have also encountered many times. For some reason, it thinks you don't have enough space even when you clearly do. Sometimes it can refuse a <1MB app when you have about 100MB free. Or it can allow a <100MB app when you have roughly 300MB free.

I don't think there is a real 'fix' to this.

Freeing up even more space should solve the problem. You can just uninstall a bunch of apps and see if it works again. Or you can clean your caches and other files you don't need (like the log mentioned by David Balažic) with an app like SD Maid, 1Tap Cleaner, or whatever app you use. Cleaning caches/tombstones/logs can easily free up a lot of space for you to install whatever app you like.

The problem will return though once you run out of space again.

The (arguably) best solution would be to have fewer apps installed (I don't like this but it's what works best for me) or buy an SD card and install apps on the SD card (with the help of an app like AppMgr III or similar).

For those with a Samsung device that splits memory in SD card and USB storage, you'll have to find a different way to actually put the apps on the external SD card instead of USB Storage. I believe I read somewhere it is possible by factory resetting the phone and then choosing to install apps on SD or something like that, but I am yet to try that.


Unfortunately, this can be the bane of many, many devices. Android needs a bit of storage left over, and won't let Google Play fill it up - god knows why, since other stuff can - and that's it.

You are not out of options, luckily. If you rooted the dang thing, you could buy a very large SD and modify the vold file to think it was internal storage.


I encountered this often before even if internal SD's free space was 2+ Gigs.

I tried this. On the terminal, type these lines:

ps set install location 1
pm get-install-location

Now, after two months and dozens of additional apps installed, the "not enough space" annoyance has not bothered me.

Hope this helps.


In my experience, I think Play Store won't let you install apps when you are running low on storage.

For example, it won't let you install even an app of about 2MB when the storage is just 90MB. This is possibly for performance issues. No one wants to install a 2 MB app that would load extra MB of data, leading to memory issues.

What I usually do is to back up large apps (even with app data), uninstall the backed-up app, and reinstall after installing the desired app. Another workaround is to get the APK from a trusted source.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .