0

I have 'Market' and every time I attempt to log into it using my Google account it says that it 'Can't establish a reliable data connection to the server.'

Any idea what could be done to get it working?

  • 1
    Are you trying to connect via wifi or mobile data? Are your connection icons white or blue? What is your mobile provider? – ale Mar 12 '13 at 12:17
  • Mobile data, white, Optus. – Jaclyn Mar 12 '13 at 12:59
  • 1
    Optus? Where is that? White connection icons indicate the device can't connect to Google servers. Can you try from wifi? – ale Mar 12 '13 at 13:52
  • @AlE. Optus is a large telecommunication company in Australia. Jaclyn, have you checked that your APN settings for optus are set right. The white icons indicate that no mobile data connection could be established. Please check the following site: optus.custhelp.com/app/answers/detail/a_id/255/~/… for the right APN settings. – Chrisii Sep 16 '14 at 10:06
1

Setting the correct System date and time.

It turns out authentication requires establishing a secure connection with Google’s server. The SSL certificate contains a expiration date which would be compared against the system date of the Android system. If the system date is too far in the past or in the future, the validation would be failed, thus the connection cannot be established. This is a security measures of the HTTPS connection, so check your system date next time encountering such strange error message.

OR

If that above fix is not working for you then you can try out ‘YouTube Connection Trick’ to rectify this problem.
Follow the below steps –

  1. Add YouTube app and login into your Gmail account.
  2. Go through the Gmail asp and add account if needed.
  3. Sign in to your Gmail account with your user name and the password.
  4. Go through your login process and now try to check Menu > Settings > Account & Sync.
  5. Select “Add account” and add a secondary account.

This solution will work out if the above doesn’t works.

| improve this answer | |
0

In what country is your ISP? Here in the Phil, its the same problem because of the unreliable network. My workaround is to use some VPN services to remedy frequent disconnects.

I currently use DroidVPN, free version limited to 100mb a day. Try it and comment on the result.

| improve this answer | |
-1

Go to your google account and turn off 2 Step Verification . . I had same problem not being able to add google account to Galaxy Ace 8530i and only solution I found was to turn off 2 Step Verification, log into my account, then turn it back on.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.