22

The Galaxy S I9000 messaging app automatically converts long SMS messages to MMS. How can I disable this?

18

You can't do so with your samsung official messaging application, all of what you can get is a pop notification that you are now in the MMS zone (Converting to multimedia message...).

I would recommend Handcent SMS application, available at the market, and has an option for not converting texts (SMS) into MMS

  • 5
    This answer should be updated: It is possible to prevent this with the offical messaging application. See these two answers. It seems that either restricted or free will work. See this question for an explanation of the creation mode setting. – Flow Oct 11 '11 at 12:17
  • @Flow : no… Even with the restricted setting, the default messaging would convert to a ᴍᴍꜱ instead of splitting into several ꜱᴍꜱ like a old Nokia would do… Many operators offers unlimited ꜱᴍꜱ for free but have data plan limits for ᴍᴍꜱ. – user2284570 Apr 20 '18 at 19:05
3

You need to change the Creation Mode in the messaging app's settings to "Restricted". I tried it on my Galaxy S II and it worked.

  • In Android 5.1.1 (Lollipop) the option for me (to set to Restricted) was "Multimedia Messages" > "Set restrictions" – Highly Irregular Aug 2 '16 at 10:11
  • In German Nougat, i find Nachrichteneinstellungen->Weitere EInstellungen->MMS->Beschränkungen festlegen=Eingeschränkt, but it still converts to MMS – Daniel Alder Mar 3 '17 at 12:25
  • Update: 1-3 SMS, if bigger->MMS – Daniel Alder Mar 3 '17 at 12:30
1

I have found this feature request with a long discussion in Android issue tracker.

From what I understand this issue was fixed long ago in stock Android starting from Froyo (2.2). But manufacturers don't tend to include this fix in their devices because it will prevent them to make money. Here is one of the relevant comments from the issue:

http://dailymobile.se/2012/02/10/the-top-5-android-anti-features/ interesting article that features this problem.

Listen, this ISN'T a bug in Android. Google fixed this years ago, manufacturers/networks don't want to include it, don't you get it? As the article I included above says, who benefits converting your FREE SMS to a PAID MMS? Not Google, the networks and manufacturers. They don't want to include it, it makes them money not too. So you're left with two options if you want to avoid it, root your phone or install an app like BigSMS.

The author of the comment recommends BigSMS as an alternative to preinstalled SMS application, but I installed Android Messages by Google and it solved the issue: my long SMS was split on 4 parts and sent without converting to MMS. See also this relevant question: "Converting to multimedia message" when forwarding large SMS.

0

You need to open the text application, then menu then settings. In settings click creation mode and then change to "free". Your problems are now over.

  • 1
    This was the default for me and didn't work. Changing to Restricted as Amit suggested did work, however. – Matthew Read Aug 25 '12 at 23:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.