2

My Samsung Galaxy S 2 just got updated software over the weekend and now it's completely different to use. I've nutted out most of it but it is no longer recognised by my laptop and I can't share or transfer files via USB anymore.

My laptop is a MAC and runs OS X version 10.7.5.

I plug my phone in and then go to settings > wireless and networks > more settings > USB utilities > Connect storage to PC but nothing happens, it just tells me it's not connected to a computer.

When I try opening my Android file transfer app on my laptop it tells me that it cannot detect an Android device.

Is there an update for my file transfer app that I'm just not finding or something? I have tried with two different cables and I still get nothing.

  • 1
    What Android version did you have before, and to which version is it updated now? My suspicion is that it was using UMS (USB Mass Storage) before, and no longer offering this now (having switched to MTP instead, which needs different software on your Mac). – Izzy Mar 18 '13 at 12:28
  • Do you have Samsung Kies? samsung.com/us/kies – CatShoes Mar 18 '13 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.