I have a Samsung Galaxy S2, running the latest CM10.1.

I lost the app drawer icon on my Dock;
I must have deleted it.
The app drawer icon lets you go to the app list, and the widget list.

How do I get the app drawer icon back?
The icon looks like a circle with 6 dots inside it.

5 Answers 5


Here are two things you can do:

(1) Download the FREE AppDrawer app from Google Play.
It gives you a shortcut to the app list.
However, it does not give you the widget list.

(2) Reset Trebuchet.

NOTE: Use the procedure below at your own risk.
It clears (or resets) the contents of your home screen.

CM10.1 uses the Trebuchet launcher.

From your homescreen,
press the left menu button, and select Manage apps.
Look for Trebuchet, and click it.
Press the Clear data button. Alternatively, you may find success (without having to repopulate all of your home screens) via simply selecting "Clear Cache" and then "Force Stop" on the Trebuchet apps menu.

  • 2
    (3) Long tap a free space on the homescreen to add a new widget/shortcut. As far as I remember there was one for the app drawer.
    – Izzy
    Commented Mar 19, 2013 at 8:13
  • 1
    @Izzy It's gone in CM10.1. That long-tap now lets you select different types of wallpapers instead.
    – geffchang
    Commented Mar 19, 2013 at 9:27
  • Only wallpapers? Gosh... And I thought that was due to some "minimalistic launcher" on my 4.1* devices (stock 4.1*, btw)... In that case I'd recommend to install a better launcher. I immediately switched to Apex Launcher, which comes quite handy on tablets as well as phones.
    – Izzy
    Commented Mar 19, 2013 at 11:48
  • @Izzy Will try out Apex and see if it's worth using. :)
    – geffchang
    Commented Mar 19, 2013 at 12:01
  • Good choice! I run it on multiple devices meanwhile. And I miss it on those which are not yet 4.x :) It's as comfortable as GoLauncher, but without all the nagging notifications (grin)
    – Izzy
    Commented Mar 19, 2013 at 14:00

This happened to me as well. I finally figured it out.

It was not actually gone - it was hiding under the Contacts icon (the blue face on the bottom right). Long press on the Contacts icon, then move the icon up.

Then you should have your 6 dots back and be able to launch apps again.

If it keeps happening, either remove all the other icons or install a different launcher.


It's possible that you reduced the number of items to show. Trebuchet doesn't move your icons when you shrink the grid; they simply remain off-screen. Check these:

  • Settings / Home screen / Dock: Icons and Pages
  • Settings / Home screen / Homescreen: Grid size and Homescreens.

I experienced the same problem with Cyanogenmod 11 and was quite disappointed that this was Cyanogemod 11's official app launcher. Icons of apps installed on SD kept disappearing after each reboot.

The only solution that worked for me was to install Google Now which installs it's own app launcher that has all the modern features and works flawlessly.



If appdrawer is missing then simply tap and hold your shortcut area i.e. your contacts, default messaging app arra, a pop up will appear, select default icon then select appdrawer, that's all you have your app opening button on your home screen. Thanks in advance

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .