In Settings > Display > Daydream I have
- selected one (any one, but right now it's just the standard Clock) - when to daydream = either docked or charging
- "start now" works fine.

I've connected my Nexus 4 by USB cable to a wall charger and "Clock" confirms Charging (AC), 45%

Settings > Display > Sleep is set to 15 seconds while I try to get daydreaming to work. If/when it works, I'll probably set it to 2 minutes.

Despite the above settings, and being on AC power, the phone never daydreams. Why not?

This is a Nexus 4 with stock 4.2.2, not rooted, not superuser'ed (yet).

  • FWIW, I also have a Nexus 4 (4.2.2) and it daydreams OK when charging (USB to wall charger) when set to sleep after 15 seconds. Presumably it does sleep after the allotted time? Is it possible there is a running app preventing it from daydreaming?!
    – MrWhite
    Commented Mar 19, 2013 at 17:49
  • @w3d - In developer options, "stay awake" is checked, otherwise the screen would just turn off, right? How could daydream even work if this is off? ... Actually, I just unchecked that to try it out, and now it works! Post your comment as an answer so I can accept it! :-D Commented Mar 19, 2013 at 19:19
  • 1
    Although "Daydream" is activated when the device sleeps and essentially overrides the devices default behaviour when the device would normally sleep. If "Stay awake" is checked then the device never triggers "sleep mode". Most people never need to go into "Developer options" (it is, after all, hidden by default on Android 4.2+), so making this a requirement would be tricky for most. "Daydream" is like a conditional "stay awake".
    – MrWhite
    Commented Mar 19, 2013 at 20:31

4 Answers 4


As mentioned in comments, I also have a Nexus 4 (4.2.2) and it daydreams OK when charging (USB to wall charger) when set to sleep after 15 seconds.

"Daydreaming" is triggered when the device goes to sleep (or when sleep mode would normally be triggered). It would seem that if the "stay awake" option is checked in "Developer options" then sleep mode is never triggered and the device never daydreams. So, the solution is to uncheck the "stay awake" option.

"Daydream" is like a conditional stay-awake option. The screen does not switch off and for this reason a device can only be set to daydream when it is connected to a power source.


Daydream doesn't trigger if Phone is switched off by button.

  • This was indeed my problem when I was testing Daydream mode. I didn't want to wait the three minutes for the screen to time out, so I kept pressing the power button. Testing went much better after I read your answer and changed my timeout to 15 seconds. Commented May 18, 2014 at 12:16
  • "if Phone is switched off" - should read: if the screen is switched off.
    – MrWhite
    Commented Jan 7, 2017 at 18:36

I had the same problem and found solution in configuration of Daydream. There is an option 'More' and then by default it is selected to start clock by docking. I've just changed it to 'both' docking and charging and that's it.

Hope it helps.


Daydream only woks when you let the phone turn off by itself. After you set the screen timeout to any time, let it shut off dont press the power button. That is why daydream wont work with the "keep screen turned on" option.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .