I just upgraded my SGS2 to 4.1.2 and I have huge problems synchronizing my Google calendar.

First of all, my Google calendar app disappeared. Until here ok, I reinstalled it from Google Play. When I try to add my google calendar accounts, they are just not there.

I try in Settings→Accounts→Google and choose my Google account to see the sync options inside. The option "Sync Calendar" does not exist anymore.

Did anyone have this problem? How did you solve it?

1 Answer 1


i just found out that there was one process - CALENDAR STORAGE - which was disabled. I enabled it, and then i could see the option SyncCalendar in my google account again.

after that my calendar is working fine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .