I accidentally set a sharing intent to always copy to clipboard. I know that usually to unbind these defaults, you go Settings > Apps > All > [bound app] and hit the 'Clear defaults' button from there, but I've had a look at all the system- or text-related things in there and I can't find anything with such a default set.

In my googling, I found this thread on XDA Developers that describes exactly this problem, but it has no responses.

If it matters, the action in question is the one the Github app uses to share issues.

  • Please take a look whether Default App Manager Lite or DefaultApp Reset might solve this. If so, I will set up a more detailed answer :)
    – Izzy
    Commented Mar 21, 2013 at 20:35
  • Thanks. Alas, neither of those list whatever action I'm trying to unbind.
    – colons
    Commented Mar 21, 2013 at 20:56
  • 1
    I was afraid of that (which is why I didn't make it an answer straight ahead). Another thing you might try: Andmade Share claims to replace the share menu. This should trigger the asking-for-action again at least :)
    – Izzy
    Commented Mar 21, 2013 at 21:02
  • Heh, brilliant. I installed that, ran the relevant share action, cancelled and then uninstalled it. Solved! Thanks a lot. Feel free to post that as an answer.
    – colons
    Commented Mar 21, 2013 at 21:36
  • Cool! That's what I hoped for. OK, I will make it an answer. Thanks for the feedback!
    – Izzy
    Commented Mar 21, 2013 at 21:37

5 Answers 5


There are multiple ways to clear "default actions":

  • Walking through the list of apps in Settings→Apps→Manage Apps, looking at each entry whether it has a "Clear defaults" button, and hit that (not very user-friendly -- and in this special case obviously not applyable, as the action seems not bound to a special app)
  • Using a helper app like e.g. Default App Manager or DefaultApp Reset (much more user-friendly -- but not suitable in this case, for the same reason as the previous point)
  • Installing another app which uses the same intent (in case of a "homescreen launcher" and the "home" key, another launcher, to give an example) -- not always easy to figure out what app might be fitting for this purpose. This is what lead to success in our case here, by installing Andmade Share
    Note: You do not need to keep that app installed. It's the installation of the app which "drops" the default. This is also the purpose why the next item works:
  • Updating/uninstalling one of the apps currently using this intent (to take above example: that's why you will be asked again when your launcher received an update) -- this point just for completeness :)
  • 1
    Just a note to anyone who stumbles across this: If you pick option three, note that you don't have to keep the new app around after you've reset the default; you can install and then immediately uninstall once you've run the action again.
    – colons
    Commented Mar 21, 2013 at 21:51
  • 1
    Good point, @IainDawson -- that was too obvious to me, so I forgot to include it (the curse of those deeper involved ;). With your permission, I will add that directly into my answer so it's not overlooked.
    – Izzy
    Commented Mar 21, 2013 at 21:53

Although the solution by Izzy (above) is brilliant, it did not work for me on Nexus 5 running Android 4.4. I ran into the bug after installing a to-do app. Every time I tried to share a page in Chrome, it defaults to Google Keep! Strange, but the problem and the solution is given here:


Essentially, you just need to go to Settings...Apps, then click the overflow menu in the top right. When it opens, select Reset App Preferences. Other than having to select my default launcher again, it seems to have solved the problem with no side effects.

Credit to tacomonstrous at Reddit for the solution.

  • Running Android 4.4 and had this issue with Chrome being pinned to copy to clipboard somehow. This solution worked great, thanks!
    – halr9000
    Commented Dec 3, 2013 at 20:48
  • This was a bug which reportedly is fixed now: code.google.com/p/android/issues/detail?id=61937 Thank goodness, because having to reset all preferences for "Disabled apps, disabled app notifications, default applications for actions, background data restrictions for apps and any permission restrictions" is going way overboard.
    – nealmcb
    Commented Aug 14, 2016 at 16:51

Another way is to select a piece of text and tap on share button in the poped-up menu. Then tap and hold on "copy to clipboard", then choose "app info". hooray! that's it.

my android is 7.1.1 and I select a text on a webpage in chrome app, so I see that share button.


It turns out that the app responsible for "Copy to Clipboard" is Drive (as in google drive), at least on my device. Clearing the defaults for that may do the trick!


You need to clear data of Android Shared Library from Settings > Applications/Apps. It is a system app. Clearing its data worked instantly for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .