I have noticed that since updating my Asus TF300T to Android 4.2.1 (official stock rom) I no longer receive delta updates (i.e. where only changes are downloaded instead of the complete file). Before the update it worked perfectly (on Android 4.1.2). The device is NOT rooted.

I have tried resetting the store's data, rolling back the store updates, and disabling the new app auto-scan. None of these worked :(

Is anyone else experiencing this on the Asus tablet, or any other Android 4.1+ device?

Update (29 Mar 2013): I have been checking this every day since posting, and finally today it seems that delta updates are working again. I guess it was a server side problem because the store was not updated on my device and I made no other changes anywhere.

Update (30 Mar 2013): And today I'm back to full updates :( This does seem to be a server side issue though; not sure if it affects any other versions/devices. If anyone on any 4.1+ build (any device) could indicate whether they have problems with it that would be great :)

1 Answer 1


I've got a Nexus S running a 4.2.2 ROM. I just noticed I'm not getting delta updates about a week ago. Though I've been on 4.2.2. for much longer, so it could be another problem not related to the Android version, especially since the Play Store can update independently from Android.

  • Thanks for responding. I assumed it was the update to 4.2 that did it (I first noticed it a week or so after updating), but it could very well be the Play Store app, or even on the server side. However, I did a bunch of searches on various sites (google, xda, etc) and could not find anyone posting about this, so it does not seem to be a widespread problem. At least this confirms that it's not just me, so thanks again for posting :)
    – free3dom
    Mar 22, 2013 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .