I have a brand new Nexus 10 which is supposed to be a present for my partner for tomorrow.

I wanted to have it rooted and set up for her before I gave it to her, so I installed WugFresh NRT on my work computer (WinXP x32) and went through the same unlock/root/flash procedure I've been through a million times with all my phones/tablets.

After unlocking, it went into TWRP and I was told by NRT that I should do a factory reset manually from TWRP - a step I've never had to do before. I followed the instructions, but the factory reset failed.

I rebooted the Nexus 10 and it just sits at the colourful 'X' forever. I can hold the power button to try again, but I can never get past this. No problem, I'll just flash CM from TWRP, right?

Well, I can get into fastboot from power + vol-, but fastboot is frozen. It doesn't matter if it's connected to my PC or not, I have "start" selected, and I cannot select anything else. Fastboot.exe won't detect the tablet, and there's pretty much nothing I can do.

I can press power to select "start" from the fastboot menu and it begins booting normally, and freezes as before.

So basically I'm stuck here. I know how to push across a recovery and re-flash the system, but I can't actually get to that stage. I'm not sure if it's a driver issue - my experience tells me it probably is. I've tried 2 different cables and all the USB ports. I can try on my home computer that has the drivers all installed, tested, and working - but I won't be home for another 12 hours or so. I actually can't even turn off the device!

I've tried the naked drivers, the google drivers, the Samsung drivers, I can't install the PDANet drivers because it wants me to install the ADB drivers first - but I can't do that because the device won't boot!. This XP machine is now a cocktail of drivers that don't work. I do actually have an "unknown device" associated with the tablet, but I have NFI what it is or what driver to install. I've tried them all, and windows just keeps saying that the driver location I've chosen doesn't have any appropriate drivers for this device.

Any suggestions?

Edit: Hmm, I've managed to get my hands on a Win8 laptop and got the drivers working so that Fastboot and ADB recognise my Nexus 4 phone. When I plug the Nexus 10, it doesn't show up in Fastboot devices.

  • I am pretty much sure it is driver problem. I too faced this issue on my windows xp machine, but worked great at very first instance in Windows 7 machine. Try the NRT's USB tools to clean up the reg entries and stick to Samsung's drivers.
    – Narayanan
    Commented Mar 23, 2013 at 5:04
  • If you can't get hold of another machine,you can consider using a virtual machine. I agree it takes more time and effort to build one for such a small and one time job. But when it comes as a Hobson's choice, what else to do?
    – Narayanan
    Commented Mar 23, 2013 at 5:08

1 Answer 1


Had similar problems. My Nexus 4 was discovered just fine, but Nexus 10 failed to be seen as an Android adb device. So I uninstalled the Nexus 4 drivers, rebooted, and then installed some unsigned drivers from internet called Naked Drivers. After that both Nexus 4 and Nexus 10 were properly recognized.

Then, attempted to unlock the Nexus 10 using WugFresh NRT (I'm lazy, I know) and after a temporary install of twrp, WugFresh NRT told me to do a factory reset to prevent a bootloop. So I did this, but it told me that it failed a couple of times. After reboot, found myself in a bootloop, exactly what I tried to avoid.

After some google search came around this movie that explains how to do a basic wipe, but from original recovery not twrp.


Written explanation of the steps from the video above (in case it goes down):

  • press and keep power, volume up and volume down to escape from bootloop and reach the fastboot menu
  • in the fastboot menu use volume up and volume down to navigate and select power off button to make a selection, so just select the recovery option
  • you will reach the recovery mode (there is an icon with android robot on his back and a "!" sign) and press quickly all three keys at the same time (power, volume up and volume down). If you succeed, a blue menu will appear, so from there, just select your wipe option.

After I tried this, it worked and found myself at configuration screen for first time setup.

Next, I downloaded latest version 2.5 for twrp, replaced the old 2.4.1 in the folder WugFresh Development\data\Recovery_Custom\TWRP. After that, using the WugFresh interface I went for the root and also checked Custom Recovery.

This time everything went smooth and also twrp was upgraded.

Hope it helps.

  • Could you please include an excerpt of the steps described behind your Youtube link? If the creator decides to delete his video (or it gets otherwise deleted), your answer will become useless otherwise. Thank you!
    – Izzy
    Commented May 15, 2013 at 18:46
  • ok, updated my answer.
    – Arise
    Commented May 15, 2013 at 21:09
  • Thank you! That deserved another +1 :) Nice step-by-step guide now.
    – Izzy
    Commented May 15, 2013 at 21:13
  • Oh my GOD THANK YOU. Literally every other guide on the internet says that you are supposed to only press power + volume up. This is the only one that says the correct command which is just a quick press of all three buttons (NOT A HOLD)
    – Will
    Commented Nov 28, 2013 at 8:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .