The Droid 4 physical keyboard has had driver/software issues forever, but this update takes the cake. Pressing shift-period and shift-comma no longer produce colon and semicolon as advertised, but instead greater-than and less-than. Is there any way to fix this? Also, in Dolphin browser the keyboard is even more broken—the symbol key acts as a second space bar and holding a key makes it repeat instead of offering alternatives. Help!

edit: following directions elsewhere I did a factory reset. The keyboard now seems to work okay everywhere except Dolphin, where the shift key doesn't latch, the capslock key doesn't work, and the symbol key is still a spacebar.

Edit 2: The latest Dolphin beta has the same problem.

Edit 3: Actually, Dolphin, Chrome, and the plain browser all have this problem. Firefox does not. DroidEdit does not, Gmail does not.


Some users have found doing a cache partition clearing has resolved the shift key issue. I have also read others that disabled the Google Chrome application, resolving the issue. I have done both but still get the shift key issues when using my browser. The cache partition clear resolved the shift key issues on the phone (ie texting or other apps). Below is a link to Motorola's step by step instructions for the partition clearing, you will not lose any data etc. Some users have gone so far as to do a factory reset with no resolution.


  • Yes, I tried the factory reset. It fixed a previous keyboard mapping issue, but not this one. I tried downgrading and disabling Chrome—no luck. The problem, oddly, seems, in my case, to affect only browsers, and not Firefox. I wonder if the rest have something in common. – dfeuer Mar 28 '13 at 17:44

I was able to correct the semicolon/colon problem by setting my keyboard to:

  • Input Method: English (US) Android Keyboard (AOSP)
  • Mapphone-switch: English (US)-Android Keyboard
  • Omap4-keypad: Default (changing to "default" and unchecking all items, including English (US), in "omap4-keypad" "keyboard layouts" seemed to fix the problem - before that change, typing ";" resulted in ">").

I also did a cache partition clear and turned off the phone, pulled the simcard, replaced the sim card and rebooted. I am not sure if any of these actions did anything (after these actions and before switching "omap4-keypad" to "default," the semicolon problem continued, but I tried them based on suggestione from other sites).

  • That futzing around with keyboard layouts only helps with the ahift key, not the symbol key, and I hate that keyboard option (prefer Swype). – dfeuer Mar 29 '13 at 15:18
  • In my case, the "futzing around" fixed the semicolon/colon problem. Now when I press the semicolon key I get ; instead of >. When I press the colon key I get :, not <. – user31248 Mar 29 '13 at 16:46
  • In my case, a factory reset fixed the colon/semicolon issue, but not the shift/capsock/symbol/hold-for-choices issues. – dfeuer Mar 31 '13 at 7:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.