My Samsung Galaxy S3 (GT-I9300) was rebooting itself for the past few days, randomly. Today, it did it again, but didn't boot back up. Instead, it is now stuck on an infinite boot loop - it gets as far as the splash screen (Galaxy SIII logo), then reboots, and this goes on forever, until I remove the battery.

The first thing I tried was to remove the battery, SIM card and MicroSD card for 5 minutes. I then wiped the Cache Partition through the Android Recovery Mode. I then did an Emergency Firmware Recovery through Samsung Kies. This didn't help - the phone is still on the same boot loop. I then tried a Factory Reset through the Android Recovery Mode. This also didn't help.

I tried to view the boot logs through the Android SDK tools, but of course, the phone won't stay on for long enough to connect via USB. I'm not sure what else to try. Is there any other way I could possibly access the device's logs? Or should I try Odin instead of Kies?

Update: my S3 was had the official stock firmware on it, with official OTA upgrades, it was never rooted.

Second update: I've now tried flashing with Odin3. I used the firmware version appropriate for my region and carrier. Everything was successful, but I'm still having the same problem. I'm guessing there's not much else left to try except bring the device back to the dealer? ...

  • I'm afraid you will have to turn it in. If neither a factory-reset nor even a re-flash solved it, I don't see much other chances. As you never rooted the device, and always stuck to Sammy's officials, there should be no problem -- and you most likely will get a replacement.
    – Izzy
    Commented Mar 25, 2013 at 7:19
  • My dad had this problem. His solution was to let me put CM11 on it ;)
    – Cornholio
    Commented Mar 25, 2013 at 14:32
  • Thankfully, I was able to fix it. I used Odin to flash it again, but this time, with an older firmware. I originally tried it with the Jelly Bean firmware. I thought it was a long shot, but decided to try again using Ginger Bread. This fixed whatever the issue was, and I used the OTA updates to get the phone back to the latest version. The thought of handing in the phone was a bit daunting. My girlfriend had to hand hers in recently. Her phone is only a few months old. It took them over a month just to admit they couldn't fix it, and she only got her replacement yesterday (after 5/6 weeks).
    – Julian
    Commented Mar 30, 2013 at 0:10
  • 1
    Julian, would you be so kind and make your last comment an answer, plus accept it after the "technical delay" of 2 days? In the comments, it might get lost -- and people with the same problem would not even read the details when there's no "answer". Thank you!
    – Izzy
    Commented Apr 20, 2013 at 15:55

4 Answers 4


I had same problem with logo loop.. I somehow screwed my EFS folder, but don't actually know how... Anyway I tried like 150 different thinks to fix it that I googled out but non of it worked for me.. Finaly I download orignal stock ROM but the old one with 4.0.4 android. Flashed via ODIN and only then get rid of logo loop and phone turned on normally (it took allmost 5 mins..) Then I restored my EFS folder. Than rooted the phone, installed CWM and made nandroid restore of my original ROM.. Not sure if this help, but saved my ass :) Wish you good luck


I had the same bootloop problem on T999 UVDLJA. I tried about 100 solutions, including flashing every possible ROM known and unknown.

Finally, the solution was very simple:

  • Flash ROM + Gapps
  • wipe cache, data, dalvik cache
  • install ROM
  • install Gapps (this is the part which I would always skip for later - BIG mistake as Gapps missing caused the boot loop)
  • restart, et voila!!!!

Try removing the power button. I had the same problem and saw on a youtube video that changing the power button was a good solution. As I could not find a spare power button on, I just decided to remove it and it actually worked! https://www.youtube.com/watch?v=pQ-U-Q_NdOo


i got similar problem with any android based on 4.4 with my i9305, any system got stuck on boot animation, tried MoKee, Omni, CyanOgen and few other ROMs plus Stock JB (however this one was bootable just by factory reset after installation), with the same result; finally i was able to go further after format /firmware folder in CWM or any other suitable recovery, actually i formatted everything excluding folders wiped by factory reset. Don't forget wipe Dalvik cache

i think this can apply for any SG3 or other new phones from Samsung

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .