Recently I happened to switch back to stock ROM in my LG P500. I used v2.3.3 (v20c) ROM from LG's site and installed wiping all partitions including my SD card.

I then rooted using SuperOneClick and installed Link2SD. I rebooted into TWRP recovery, partitioned my SD card with one ext3 and one swap partition. The remaining space on the SD card was filled with a FAT partition. After rebooting phone normally, I used Link2SD which detected the presence of ext3 and mounted it successfully at very first run. To test the mount, I restated the phone (with reboot command in terminal emulator) and the ext3 partition was mounted without any problems.

Having faced a issue with ext3 partitions (see my earlier question) I decided to first test the backup and restore features first. Hence I moved Google Maps app to ext partition and created a link. With link created, maps was working fine.

I then took a backup with TWRP which included all partitions (system, data, boot, recovery, cache, .android_secure and sd-ext). I immediately restored the backup and to my surprise, Link2SD did not mount the partition and reported an error invalid argument.

My phone does not have busybox installed and also no init.d support. But even without these Link2SD mounted the second partition well and fails after restore.

Can someone explain why it fails to mount after restore when it did before?

Update: I had sent email to the developer of Link2SD with logcat and as of now I haven't got any reply. The log cat did not show any suspicious entries (or I do not know what to look for!). The only two lines about Link2SD are:

I/ActivityManager( 1567): Starting: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.buak.Link2SD/.Link2SD } from pid 1680 I/ActivityManager( 1567): com.android.server.am.ActivityRecord 444 Displayed com.buak.Link2SD/.Link2SD: +387ms

This logcat is also available here for a detailed view.

Update 2: I missed to add that, with Link2Sd not mounting, if I go ahead and format the SD card and re-partition using TWRP recovery, Link2SD starts recognizing and mounting. So, something happens to the partition during restore operation. At next available opportunity, I will attempt to manually mount the partition as Izzy had kindly suggested.

  • Maybe the restore messed up something? Have you checked logcat/dmesg for additional information?
    – Izzy
    Commented Mar 25, 2013 at 8:38
  • @Izzy, I've added logcat. I tried this more than once and it failed every time after restore. Restore 'seems' successful - 1) the partition used size seems to be same after and before and 2) verification of backup zip file by TWRP passed without issues.
    – Narayanan
    Commented Mar 25, 2013 at 10:03
  • I must leave this for somebody else (cannot access the logcat due to corporate proxy is blocking zippyshare). Have you checked the partition (type correct, manually mountable, files accessible)?
    – Izzy
    Commented Mar 25, 2013 at 10:25
  • I haven't tried to manually mount. I missed to do it. Presently had I partitioned my SD card now to make the Link2SD to work. I'll check next time.
    – Narayanan
    Commented Mar 25, 2013 at 10:52

1 Answer 1


I have the exact same problem, the only thing that fixes is doing:

 e2fsck -fpDC0 /dev/block/mmcblk0p2

but I have to do it every boot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .