On my laptop I have Ubuntu 12.04.

1) mounting the tablet

$ sudo mkdir /media/tb
$ sudo chmod 777 /media/tb
$ sudo mount /dev/sdc /media/tb

2) downloading and updating Android SDK

$ cd ~
$ wget http://dl.google.com/android/adt/adt-bundle-linux-x86-20130219.zip
$ cd ~/adt-bundle-linux-x86-20130219/sdk/tools
$ ./android update sdk

3) editing rules for my device. Each hardware device has its ID. According to Archos website my vendor ID is e79. According to this website I should also edit ~/.android/adb_usb.ini.

$ sudo vim /etc/udev/rules.d/51-android.rules

After editing the file has this content:

SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device",
ENV{PRODUCT}=="e79/*", MODE="0666"
SUBSYSTEM=="usb", SYSFS{idVendor}=="e79", MODE="0666"

$ sudo chmod a+r /etc/udev/rules.d/51-android.rules
$ sudo vim ~/.android/adb_usb.ini

after editing the file has this content:


$ sudo chmod a+r ~/.android/adb_usb.ini

4) updating the information

$ sudo udevadm control --reload-rules
$ cd ~/adt-bundle-linux-x86-20130219/sdk/platform-tools
$ ./adb kill-server
$ ./adb start-server
$ sudo reboot
$ sudo mount /dev/sdc /media/tb
$ cd ~/adt-bundle-linux-x86-20130219/sdk/platform-tools
$ ./adb start-server
$ ./adb devices

List of devices attached

You can see that I have problem with attaching my device.

What else would you try to solve it?

  • 1
    Do you have USB Debugging enabled on your tablet? Most devices are not listed without that, as this setting starts the ADB service on the device.
    – Izzy
    Mar 27, 2013 at 16:03
  • @Izzy Probably no. I can't change anything in the tablet settings now (it's in the endless loop), I can only press the force close button.
    – xralf
    Mar 27, 2013 at 16:12
  • Yepp, I remember. I was hoping you would remember if you had enabled it previously. In that case, I guess, you'll have to solve the other issue first (most likely via a factory-reset). Then check again with USB-Debugging enabled -- and report back if it worked out.
    – Izzy
    Mar 27, 2013 at 16:18
  • @Izzy USB Debugging solved it. You can write as the correct answer and I will accept it. Thanks.
    – xralf
    Mar 27, 2013 at 19:09

1 Answer 1


For adb devices to list your device (and other ADB commands to be able to work with it), you need to enable USB Debugging in your Android device. This will start the required services (the ADB daemon) on the Android device, which is what then responds to ADB commands issued from your computer.

Besides: If you are not going to use all the development stuff from the SDK, but simply wnat to interact with your device using ADB commands, you don't need to install the entire SDK overhead. See Is there a minimal installation of ADB? for details :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .