I purchased a Note 2 clone from dhgate which is running on Android JB 4.1.1. I tried to root it with the binary method and it failed. Please find the messages below.

__________________________________________________ __________________________________________________ ___________________
C:\Root_with_Restore_by_Bin4ry_v17\Root_with_Resto re_by_Bin4ry_v17>RunMe.bat
================================================== ====================
This script will root your Android phone with adb restore function =

= Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea) =

= Idea for Tablet S from Fi01_IS01 =

= (22.11.2012) v17 =

================================================== ====================

Device type:
1) Normal
2) Special (for example: Sony Tablet S, Medion Lifetab)

x) Unroot

Make a choice: 1
Checking if i should run in Normal Mode or special Sony Mode

Please connect your device with USB-Debugging enabled now

remote object '/system/app/Backup-Restore.apk' does not exist

remote object '/system/bin/ric' does not exist


Normal Mode enabled!

Pushing busybox....
3881 KB/s (1085140 bytes in 0.273s)

Pushing su binary ....
3207 KB/s (91980 bytes in 0.028s)

Pushing Superuser app
3940 KB/s (996704 bytes in 0.247s)

Making busybox runable ...

Please look at your device and click RESTORE!

If all is successful i will tell you, if not this shell will run forever.

Running ...

Successful, going to reboot your device in 10 seconds!

Waiting for device to show up again....

Going to copy files to it's place

**mount: permission denied (are you root?)**

You can close all open command-prompts now!

After reboot all is done! Have fun!


Press any key to continue . . .

I ran the adb shell and I tried to do an su and I see no popups on my phone. I tried to run the mount command manually to mount the /system file system in read-write mode and I got the message "mount: permission denied".

I did more research and I could see that ro.secure in my boot.img might have been set to 1 and it looks like I need to use Linux to extract the boot.img, make the change and re-pack it. Where can I get the Linux Drivers for MTK6577 phone. I have Linux Mint at home and it did not recognize the phone when I plugged in via USB. Or is there an easy way to root this device?


On some MTK65xx device, the Bin4ry script failed to reboot the device after the first step. So, you have to do that manually.

So, right after this line appear "Successful, going to reboot your device in 10 seconds!" wait until the Restore data closes, then reboot

I have the same problem with my local branded tablet, and manual reboot solved the problem, and the script proceed to step 2 and finished the rooting process.

  • can you write step by step.... can't understand you clearly.... sorry – user32758 Apr 23 '13 at 14:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.