I saw some similar questions along these lines with newer Samsung devices, but I will post a question here anyway in case an answer for me ends up being an answer different than that for someone else. I have not seen a post concerning my particular phone, Mac hardware, and Mac OS.


My Mountain Lion MacBook Pro (10.8.3) doesn't recognize my Samsung Galaxy S3 (4.1.1) for file transfer over USB. I am trying to use Android File Transfer, having been promised that it would solve all my woes.

The Situation:

I've downloaded Android File Transfer, and, when connected with my device, the app launches, but it just continues to demand that I attach the USB cable and or restart my device.

What I've tried doing:

Settings > Applications > Development > USB debugging

When set to on, nothing happens. When set to off, nothing happens either. I've turned it on, then on and off, then off, and restarted before, during, and after connection, and every combination possible. The result is the same: app launches and then gives error message.

USB Cable:

I've tried with two different new cables and the error message is the same.

Connected to a Windows device:

My phone is recognized just fine by my desktop PC running Windows 7. The phone is recognized and the SD card is recognized, and I can transfer files between them. However, my Windows device is not my primary computing device, and I am frequently away from home (otherwise, at this point, I would chuck the Mac and that would be that).

As with the person who posted a similar question about the Galaxy S2, please do not post answers suggesting the use of Kies, Bluetooth, Wireless, and the like unless they lead to me being able to use Android File Transfer via USB. I want my phone to work over USB and with AFT for a reason (speed, convenience, and better synchronization). Kies seems to be the default suggestion to solve this issue, but it is terribly buggy and it accomplishes file transfer much the same way that nuking my house would get rid of spiders. (Always good to have a little levity at this level of frustration.)


6 Answers 6


https://discussions.apple.com/thread/4163985?start=0&tstart=0 Android File Transfer worked with S3 on Mac running Snow Leopard once I used the right cable! I discovered I had 2 different type USB cables- one seems to just charge and so Android File transfer didn't recognize the phone at all. The other cable, bearing the Verizon label, was entirely different. Please see link above and go to my posting under Interpret for full explanation.

Post from linked site:

As already mentioned, download and install Android File Transfer app . NOTE: To connect be sure to use the right cable- in my case, I discovered 2 cables - one is a USB plain one that just charges the phone. After much frustration I discovered there was another one (it has a Verizon label in my case.) They both seem to be USB cables but I discovered one works with Android File Transfer and not the other.

When I connected the wrong one, Android File Transfer said: No Android device found. Please connect your Android device with a USB cable to get started. I wasn't getting any notification or option on my phone to switch any configuration menu.

When I switched to the right cable however, I got a notification in the top notification area of the phone stating:

Connected as an installer and a USB icon next to it. Swiping down the top notification part there was yet another notification stating Connected as a media device. Touch for other USB options. Tapping on that statement I got the following screen:

USB PC Connection

Connect as

Media Device (MTP) box to check

xxx explanatory text which mentions you can sue Android File Transfer on a Mac in this mode

Camera (PTP) box to check

xxx explanatory text (transfer to PC that does not support MTP)

(Note that these options were not available and not displayed with the wrong cable. I noticed many users stating they don't see that menu, wonder if the culprit is the cable being used.)

I checked off MTP box and voila, clicking on the Android File Transfer icon I could see the files organized under Phone and Card and had access to them.


I was in the same situation until just now. Let me start by saying that you should not disregard the suggestions that I make right away simply because i spent all day attempting to figure this out. lol

So, like i said, i was in the same boat:

  • USB debugging - didnt work (checked and unchecked)
  • PTP and MTP combos of all types - didnt work
  • 3rd party programs - didn't work

This is exactly how my s3 came to work with AFT via USB:

  • I installed AFT on my computer and it brought up the error messages that everyone else gets. Essentially it was saying that my s3 didnt exist.
  • I never previously had KIES installed on my mac (os x mountain lion 10.7.5)
  • I proceeded to install KIES (in a futile attempt at anything that might work)
  • It worked for MTP, however i couldnt physically access the files i needed to access on my phone so i deleted it using the uninstaller.
  • After deleting KIES, I tried one last time (using the Samsung USB that came with my phone) to open AFT and it worked.

There is just no logical reason why it started to work after installing, then uninstalling KIES however it DID in fact work so give it a shot if you havent already.

Best of luck to all of you poor s3/mac owners who are still trying to fix it. I feel for you.


I too struggled with that. Kies is the problem indeed. Just throwing it in the trash did not work. You have to download it again to get the dmg and then use the uninstaller.

AFT was not working on 2 boxes I have here (10.6.8 and 10.9.5) and after properly uninstalling kies, everything started to work perfectly.


Do you have Kies installed on your computer? It tends to interfere with Android File Transfer. If you do, find the Kies dmg file you used to install Kies, and open it. You should find the uninstaller in there. click on it to uninstall Kies, and then try connecting your phone with Android File Transfer.


I just had the same problem earlier today -- after months of no trouble, the AFT no longer would recognize that a phone was connected, and the little USB icon would not show up on the phone notification bar (although the phone WOULD charge).

Here is the fix that worked for me:

I had been using a standard USB 2.0 Micro-USB cable, and up to today I had had no trouble with the phone's being recognized by the AFT.

Once the trouble started today, I brought out the USB 3.0 Micro-USB cable that comes packed with the phone. With that cable the connection with AFT still works fine.

Why the sudden change -- I have no clue.


After struggling with this issue for many days, uninstalling Kies finally did the magic for me!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .