I've been using my Google Nexus S with Cyanogenmod 7 for about a year now. Sometimes it rebooted out of the sudden or locked up but all in all worked well.

Today I rebootet the phone und since then it hangs during boot at the animation with the rotating circle.

How do I fix the phone and get it booting again?

Unlike many issues I found on the web I did not play with the firmware recently. Unfortunately it's been quite long since the last backup. I need to dig my data from the device.

Ways acceptable for me to go:

  1. analyzing and fixing the issue
  2. getting all my data and install new firmware (while updating to CM10)

Analyzing the issue

I installed the Android SDK on my computer (for adb and fastboot) and successfully ran ClockworkMod Touch Recovery image which proves the the phone hardware is actually fine. Copying files from the /sdcard directory worked and I could open a shell but adb logcat doesn't work for me. The program keeps "waiting for device".

This is what I had done before:

  • phone hung and restarted by removing and reinserting battery
  • date and time were set to 2005-01-01 00:00, reset (never had that before)
  • installed or updated several apps through F-Droid app "store"
    • installed And Bible
    • updated Barcode Scanner
    • maybe updated/installed something else, but can't remember because I browsed through F-Droid quite a long time and read dozens of app descriptions
  • status bar crashed, phone still usable but started reboot to get status bar again
  • Booom! Phone hangs forever on boot animation

I have the feeling that the Google logo with the open lock which is displayed before the CM boot animation begins stays longer than before. But I am everything but sure.

Making backup

As I cannot run any backup apps I have difficulties doing a reliable backup. I set up my phone not to sync most of my data to Google. Yes, I missed doing regular backups for some time because I find doing so is not elegantly possible with Android (compared to tar c /home or even mksquashfs or rsnapshot on Linux).

What I need at least in declining order of priority:

  1. calendar
  2. contacts
  3. some app's data
  4. saved wireless credentials

What I already got using ClockworkMod Touch Recovery:

  • copying /sdcard with adb pull
  • Running backup from the ClockworkMod Touch Recovery menu -- I have no clue what is actually backed up

The ideal way would backup the whole phone so I could install CM10 and retrieve any missing data from the backup or restore the backup to get the current state.

Any suggestions?

  • 1
    I installed the SDK and successfully ran Clockwork Recovery image Clarify this? Do you mean you went into CWM recovery? The status bar crashing.. installed or updated severall apps through F-Droid app "store" what apps did you install exactly for this to happen? A Nexus was out since circa December 2010 - so how did it revert back to 2005? – t0mm13b Mar 29 '13 at 23:42
  • I guess Android will set the data back to 2005 by default. Probably that not a question of the individual device. But I don't know for sure. I update my question with details you requested. – daniel Mar 30 '13 at 11:59
  • And the apps? What sort of apps did you install as well? Might help to post a logcat by plugging in USB and reboot handset and capture the logcat, (from boot, to full Android environment) into pastebin – t0mm13b Mar 30 '13 at 16:40

It could even be a corrupted cache file. If you are able to boot into recovery (CWM) you can perform backups, wipe dalvik-cache and cache and install a current CM7.2. Once in recovery you should be able to mount /data with adb also to run tar, but try the gui.

  • Will wiping dalvik-cache, wiping cache or install CM7.2 harm my data? I find loads of forum posts but could not verify that. What portion of my data is contained in /data? If I backup /data and install CM10 will I be able to use the old data? – daniel Mar 30 '13 at 11:56
  • all your data is in.data, nothing in cache. Yes, you can upgrade, though certain apps may need their data cleared. – daithib8 Mar 30 '13 at 18:36

First wipe the Dalvik cache, then reboot. If that doesn't work, wipe the cache too.

If clearing cache is not working:

  • Backup your device's system partition with adb pull /system
  • Backup the data partition with adb pull /data
  • Or use adb backup -apk -shared -all -f something.ab

After that do a factory reset and restore the backup afterwards.

  • I would say save the trouble of using ADB if one already has the custom Recovery installed which can take Nandroid backups. – Firelord Jul 22 '15 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.